[vdr] pvrinput radio - need analogradio??

Simon Baxter linuxtv at nzbaxters.com
Wed Feb 14 04:33:25 CET 2007


>> In order to get the correct info from a v4l2-ctl --all:
>> Format:
>>         Type            : VBI Capture
>>         Sampling Rate   : 27000000 Hz
>>         Offset          : 248 samples (9.18519e-06 secs after leading
>> edge)
>>         Samples per Line: 1440
>>         Sample Format   : GREY
>>         Start 1st Field : 6
>>         Count 1st Field : 18
>>         Start 2nd Field : 318
>>         Count 2nd Field : 18
>> Video input : 0 (Tuner 1)
>> Audio input : 0 (Tuner 1)
>> Frequency: 1440000 (90.000000 MHz)
>> Video standard = 0x000000ff
>>         PAL-B/B1/G/H/I/D/D1/K
>> Tuner:
>>         Capabilities         : @@ -881,12 +881,19 @@
>>  bool cPvrDevice::Tune(int freq)
>>  {
>>         struct v4l2_frequency vf;
>> +        int freqaux = freq;
>>
>>         memset(&vf, 0, sizeof(vf));
>>         vf.tuner = 0;
>> -       vf.type = V4L2_TUNER_ANALOG_TV;
>> +        if (freq < 88000000)
>
> I think this don't work. I use freq >180000 because 180000   is the max
> range
> for FM.
> You can also use:
>
> if (radio_fd >= 0)
> 	radio
> else
> 	tv
>
> Jose Alberto

I've found some weird stuff.  When vf.tuner is set to V4L2_TUNER_RADIO the
freq seems to be a factor smaller.  In experimenting, I find if I set the
channels between 88000000 & 108000000 (for 88-108Mhz - looks like this is
set as Hz ???) monitoring what's been set on the PVR-150 with 'v4l2-ctl
--all', I see these values set the correct freq and I get a 50% or better
signal strength.  What's more, the 'v4l2-ctl --all' matches what's set
with a 'ivtv-radio -f90.0'.

Problem is, no audio is output!!  It looks like the v4l2 tuner is set to
radio, the tuner is set to 90.9Mhz, but it's trying to play the stream
from /dev/video0 rather than /dev/video24.  Does this make sense??




More information about the vdr mailing list