[vdr] vdr-ttxtsubs in vdr developer versions?

Magnus Andersson svankan at bahnhof.se
Wed Jun 27 21:00:24 CEST 2007


Hello!

Does vdr-ttxtsubs plugin work with any of the latest vdr developer versions?

I have patched vdr with
vdr-1.5.5-subtitles-0.5.0-and-ttxtsubs-0.0.5.diff and the plugin itself
with vdr-ttxtsubs-0.0.5-kermanekka-edition.diff.

http://users.tkk.fi/~rahrenbe/vdr/

On my Gentoo amd64 system with kernel 2.6.20 I get this message when I
try to compile:

teletext.h:30: warning: ‘__packed__’ attribute ignored for field of type
‘uint8_t’
teletext.h:31: warning: ‘__packed__’ attribute ignored for field of type
‘uint8_t [2]’
teletext.h:32: warning: ‘__packed__’ attribute ignored for field of type
‘uint8_t [40]’
teletext.h:37: warning: ‘__packed__’ attribute ignored for field of type
‘uint8_t’
teletext.h:38: warning: ‘__packed__’ attribute ignored for field of type
‘ttxt_data_field [1]’
ttxtsubsdisplay.c: In member function ‘void cTtxtSubsDisplay::ShowOSD()’:
ttxtsubsdisplay.c:415: error: ‘SetCode’ is not a member of ‘cFont’
ttxtsubsdisplay.c:415: error: ‘I18nCharSets’ was not declared in this scope
ttxtsubsdisplay.c:438: error: ‘SetCode’ is not a member of ‘cFont’
ttxtsubsdisplay.c:463: error: ‘SetCode’ is not a member of ‘cFont’
make: *** [ttxtsubsdisplay.o] Error 1

/Svankan



More information about the vdr mailing list