[vdr] softdevice with menu&audio but no video

Stefan Lucke stefan at lucke.in-berlin.de
Fri Jun 29 13:11:48 CEST 2007


Quoting Darren Wilkinson:

> Stefan Lucke wrote:
> > Quoting Darren Wilkinson:
> >
> >
> >> Torgeir Veimo wrote:
> >>
> >>> On 27 Jun 2007, at 18:32, Darren Wilkinson wrote:
> >>>
> >>>
> >>>> The problem
> >>>> is that although I can hear the channel playing and I can see and use
> >>>> the vdr menus using softdevice I can't view the actual program wether or
> >>>> not it's live or recorded.
> >>>>
> >>> Ae you using Xv output? It's prob the wrong colour key used for the
> >>> overlay. Search the softdevice devel for a fix.
> >>>
> >>> --Torgeir Veimo
> >>> torgeir at pobox.com
> >>>
> >>>
> >> I forgot to mention that I'm using DirectFB only.
> >>
> >>
> >
> > And you forgot to mention which hardware you are using.
> > With DirectFB we need hardware YUV -> RGB conversion support.
> >
> > Plain fb output mode should run on any hw, but requires some
> > more CPU power.
> >
> > Stefan Lucke
> >
> >
> I'm using nvidiafb with a GF 6600.

6600 ... I think that was the series, where they (nvidia) dropped
the overlay unit. When I remind this correct, from this series on only
the blitter can be used. So it _could_ be, that when selecting YUY2 as
output pixel format _and_ setting "Use StretchBlit" to yes, video is shown.
But this depends on DirectFB's driver capabilities too.

> However normal framebuffer is also
> showing menus but no video. Also shouldn't colourspace errors mean I get
> no menus either?

Menus are drawn directly to framebuffer in RGB.

Stefan Lucke



More information about the vdr mailing list