[vdr] Vdr or driver performance dropout

Marko Mäkelä marko.makela at hut.fi
Fri Mar 9 13:45:58 CET 2007


On Sat, Mar 03, 2007 at 10:12:21PM +0200, Kartsa wrote:
> I did a seven minute session where I had 5 test recordings which started 
> one minute apart and ended at the same time. After each recording had 
> started I tested the responce of remote by just pussing menu button. 
> After three recordings there began to be delay in menu appearance and 
> after fourth recording the menu came up in pieces and after fifth 
> recording there were no menu or if it ever did appear after several menu 
> presses it was incomplete. This can be seen in the log (timeout waiting 
> in LoadBitmap). Playback of a recording started to have small problems 
> after third recording started and with four and five simultaneous 
> recordings you really do not want to wath a movie like that.

If I were you, I'd run OProfile only during the heavy-load situation (3
recordings running, when you are browsing the EPG menu.  I'd try something
like this:

opcontrol --reset
sleep 2;opcontrol --start;sleep 20;opcontrol --stop

After that, you have 2 seconds to start browsing the EPG and 20 seconds
to keep browsing.  (Or to start playback and keep watching it.)

After this is done, look at

opreport -l /path/to/vdr | less

Obviously, you should compile vdr with debugging symbols enabled
(CFLAGS and LDFLAGS containing -g).

I'll lose this mail account at the end of this month, and I think I will
unsubscribe from most mailing lists, including this one.  We can continue
this off-list.  You can find my email address at the bottom of my home page,
http://www.iki.fi/~msmakela/.

	Marko



More information about the vdr mailing list