[vdr] dxr3 and 1.5.11 antialiasing

Jan Willies jan at willies.info
Wed Nov 14 14:38:39 CET 2007


Luca Olivetti wrote:
> En/na Jan Willies ha escrit:
> 
>> After upgrading from 1.5.2 to 1.5.11 I ran into some problems with my 
>> dxr3 card. The first one was solved by setting AntiAlias = 0 in 
>> setup.conf. But after that, VDR won't even start:
>>
>> vdr: [3936] ERROR: FreeType: error during FT_Render_Glyph 32, 3
>> vdr: [3936] ERROR: FreeType: error during FT_Render_Glyph 32, 3
>> vdr: [3936] ERROR: FreeType: error during FT_Render_Glyph 32, 3
>> Speicherzugriffsfehler
>>
>> (http://article.gmane.org/gmane.linux.vdr/33161/).So is this a freetype 
>> problem? wrong font? More infos needed?
>>
>> libfreetype6 2.3.5-1+b1
>> libfreetype6-dev 2.3.5-1+b1
> 
> FWIW I have 2.3.1 (the version that came with mandriva 2007.1).

Seems that debian only has Version: 2.3.5-1+b1 and Version: 
2.2.1-5+etch1. Unfortunately, 2.2.1 seems pretty old when trying to 
downgrade:

The following packages have unmet dependencies:
   libmagick++9c2a: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 
is to be installed.
   libfontconfig1: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is 
to be installed.
   libgd2-noxpm: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is 
to be installed.
   xpdf-utils: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is to 
be installed.
   fontconfig: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is to 
be installed.
   libxfont1: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is to 
be installed.
   libpango1.0-0: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is 
to be installed.
   xpdf-reader: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is to 
be installed.
   libpoppler1: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is to 
be installed.
   xfonts-utils: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is 
to be installed.
   libgd-gd2-noxpm-perl: Depends: libfreetype6 (>= 2.3.5) but 
2.2.1-5+etch1 is to be installed.
   perlmagick: Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch1 is to 
be installed.

I don't want to hose my system, so I guess I'm waiting for an freetype 
upgrade in debian.


- Jan




More information about the vdr mailing list