[vdr] dxr3 and 1.5.11 antialiasing

Ville Aakko ville.aakko at gmail.com
Fri Nov 23 13:55:20 CET 2007


(please don't top post)

2007/11/23, Theunis Potgieter <theunis.potgieter at gmail.com>:
> Is this related to `xine -V xxmc` too? The skin skinsoppalusikka's colours
> appears wrong when I use the video driver xxmc in vdr-xine. It also appears
> to do a "clearscreen" everytime the OSD updates, which is annoying if you
> have the playback bar updating every second.

I haven't used xine, so I really don't know. Maybe I should test it with dxr3...

But, I also notice that skinsoppalusikka displays wrong colors in the
display logos, if you constantly change channels - if you wait until
the OSD clears (i.e. the channel info is not displayed anymore), then
the logo is displayed correctly when you change a channel. It seems as
if the palette isn't updated if you don't let the OSD clear itself. Is
this what you meant? Otherwise the OSD's colors are correct.

Occasionally the OSD freezes (i.e. it is unresponsive for a while),
or, more commonly,  becomes garbled, i.e. as if the OSD was out of
sync for a second or a few more. These are the dxr3-specific problems
I was referring. DXR3 users get them with ANY OTHER SKIN than
text2skin (and enElchi), even the default ones (console and st_tng) -
they are NOT soppalusikka specific. I haven't noticed any problems
with the refreshing OSD on dxr3 (i.e. everything is displayed
correctly), but if that really is happening, it could explain why
skinsoppalusikka occasionally hangs and becomes garbled on dxr3.

 - Ville

p.s. I also noticed that text2skin being unusable in 1.5.11 is caused
by some skins (not enElchi) that used to work before, crashing the
whole thing when the files are loaded by text2skin. By removing them I
got the text2skin working again. Maybe I should post a message here
about 1.5.1x and dxr3 at some point, with all the patches I've
gathered...

-- 
Ville Aakko - ville.aakko at gmail.com



More information about the vdr mailing list