[vdr] VDR continuously initializing CAM

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Sat Apr 12 11:11:52 CEST 2008


On 04/11/08 23:10, Arthur Konovalov wrote:
> Klaus Schmidinger wrote:
>> Well, actually it's only one place there where false is returned,
>> and that's when the "alive" timer times out, which is apparently
>> after the 2 seconds between the resets you're observing, see
>>
>> #define TC_ALIVE_TIMEOUT 2000
>>
>> One possible test would be to increase this time and see whether
>> this increases the distance between resets - or makes them go away
>> at all.
>>
>> Depending on the result of this test we'll see how to continue.
> 
> Meanwhile I increased constant
> 
> MODULE_CHECK_INTERVAL to 300 ms
> 
> and now syslog looks much better.
> 
> Currently I have not display (ssh session only) and can't verify final 
> result.
> 
> Is it possible that is OK now?

What you're achieving with this longer timeout is that the module status
is checked less often. If this leads to an improvement, I guess it means
that getting the module status is somehow broken, because it really should
be allowed to get te module status at any time (or does anybody know of
some specs that say otherwise?).

This might be the reason why you don't have trouble with other apps,
because maybe they don't check the module status (or at least not that
often).

At any rate, if this really fixes the problem for you (please let us
know whether it actually work in the long run) I guess it shouldn't
be wrong to generally set this timeout to 300ms - or maybe even more?
Like 1000ms or so?

Klaus



More information about the vdr mailing list