[vdr] xineliboutput - problems with the media player

Segers,Jan J.K.T. jan.segers at student.fontys.nl
Thu Apr 17 14:09:19 CEST 2008


hello,

im using xineliboutput and sxfe via remote.
my system is debian etch with e-tobi vdr 1.6 and e-tobi xineliboutput packages (1.0.0~rc2+cvs20080223). my output is via VGA using XV with openchrome drivers (mainboard is epia pd 1ghz).

when i use the media player i experience several problems:

playback of jpeg files does not work. as soon as i select a jpg file the screen goes black and X freezes. i have to restart X in order to get back to my vdr because OSD does not respond anymore.
syslog:
Apr 17 11:49:55 mumeclient vdr: [18368] [xine..put] cPlaylist::EscapeMrl('/usr/src/mnt/pictures/IMAG0010.jpg')
Apr 17 11:49:55 mumeclient vdr: [18368] [xine..put]     --> '/usr/src/mnt/pictures/IMAG0010.jpg'
Apr 17 11:50:01 mumeclient vdr: [18372] [xine..put] Invalid re-send request: 243-50 6 (send pos=0)

also playback of dvd images seems not to work very well (atleast for me). the dvd image directory is well recognized as "D" and i get for a split of a second the menu of the dvd, but after that: same story: screen goes black and X freezes.
syslog:
Apr 17 13:36:04 mumeclient vdr: [18368] [xine..put] cPlaylist::EscapeMrl('dvd:/usr/src/mnt/video/BEE_MOVIE')
Apr 17 13:36:04 mumeclient vdr: [18368] [xine..put]     --> 'dvd:/usr/src/mnt/video/BEE_MOVIE'
Apr 17 13:36:04 mumeclient vdr: [18372] [xine..put] Invalid re-send request: 162-162 8 (send pos=0)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(0 ?)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 )
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 )
Apr 17 13:36:05 mumeclient vdr: [18368] [xine..put] cXinelibPlayer playing dvd:/usr/src/mnt/video/BEE_MOVIE (OK)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(0 ?)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 menu)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 menu)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(0 ?)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 menu)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 menu)
Apr 17 13:36:05 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
last 5 lines repeat

playback of audio works, but maybe i found a bug:
i select an album & start playback. i open the playlist with red, choose another track and press ok and then the OSD gets very huge so that i only can see a part of it on the screen and it does not disappear anymore.. i have to stop the playback in order to get back to a normal OSD. that behaviour is not the same for every track, for some the OSD gets resized to 1/4 of the screen for 2-3 seconds, then gets normal again.

here is a photo i took from the huge sized osd:
http://img501.imageshack.us/img501/3707/fotos0079ie9.jpg

syslog:
Apr 17 13:44:47 mumeclient vdr: [18372] [xine..put] Invalid re-send request: 255-62 6 (send pos=0)
Apr 17 13:45:03 mumeclient vdr: [18368] [xine..put] OSD bandwidth: 234070 bytes/s (1828 kbit/s)
Apr 17 13:45:06 mumeclient vdr: [18368] [xine..put] cPlaylist::EscapeMrl('/usr/src/mnt/audio/Editors/An End Has A Start/06-ed
itors-the_racing_rats.mp3')
Apr 17 13:45:06 mumeclient vdr: [18368] [xine..put]     --> '/usr/src/mnt/audio/Editors/An%20End%20Has%20A%20Start/06-editors
-the_racing_rats.mp3'
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(0 ?)
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 )
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(0 ?)
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] DVDTITLE DVDTITLE 0
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] cXinelibPlayer::SetSubtitleTrack(49 )
Apr 17 13:45:06 mumeclient vdr: [18368] [xine..put] cXinelibPlayer playing /usr/src/mnt/audio/Editors/An End Has A Start/06-e
ditors-the_racing_rats.mp3 (OK)
Apr 17 13:45:06 mumeclient vdr: [18372] [xine..put] Invalid re-send request: 242-242 6 (send pos=0)

__________
M. v. g.  
          
Jan Segers




----------------------------------------------------------------
Op deze e-mail zijn de volgende voorwaarden van toepassing:

http://www.fontys.nl/disclaimer

The above disclaimer applies to this e-mail message.
----------------------------------------------------------------



More information about the vdr mailing list