[vdr] iptv FILE .ts stalling & not switching streams

Rolf Ahrenberg rahrenbe at cc.hut.fi
Fri Apr 18 07:45:53 CEST 2008


On Fri, 18 Apr 2008, Simon Baxter wrote:

> 1) Firstly, the FILE option.
> When I select this channel, the video and audio play for 2 seconds, then stutter at about1 fps, then another 2 seconds etc etc.

The FILE protocol was meant only for development phase. It has buffering 
problems and you'll have to tweak the buffer size to avoid buffer under- 
and overflows.

> FileTest;IPTV:5:IPTV|S0P2|FILE|/video/vdr/Stream1_Unscrambled_030308.ts|5:P:0:35+514:34:2321:0:3:0:0:0

The "S0P2" should be "S0P1". Only 0 or 1 are defined, but any non-zero 
value will be handled like 1 at the moment.

> buffered 8.0 frames (v:15.8, a:8.0)

These are not originating from iptv plugin nor vanilla vdr, but maybe 
from an output device plugin (xine/xineliboutput/softdevice) you're 
using.

> 2) Although the other PIDS get picked up within the stream, when I try to select one of the other streams, I only get the "Arts Channel":

You've activated the pid scanner and it doesn't handle multiple 
video/audio pids, but detects always only the first one.

> 3) I'm also having problems selecting the various EXT channels.  Only NASA will start - what's wrong with my syntax?
> NasaTV Public:1:IPTV|S0P0|EXT|iptvstream.sh|1:P:0:2:3:0:0:1:0:0:0
> NZ Govt TV:2:IPTV|S0P0|EXT|iptvstream.sh|2:P:0:2:3:0:0:1:0:0:0

The video and audio pids are the same for all of these. If you're using 
the example iptvstream.sh script as a template, you should enable the 
pid scanner for these or manually correct the pids: video pid is 
parameter plus one and audio pid is parameter plus two:

NZ Govt TV:2:IPTV|S0P1|EXT|iptvstream.sh|2:P:0:3:4:0:0:1:0:0:0

BR,
--
rofa



More information about the vdr mailing list