[vdr] Live-TV picture goes away on composite out of ttpci

Jens Ziller zillerbaer at gmx.de
Mon Dec 8 20:42:47 CET 2008


Am Montag, 8. Dezember 2008 schrieb Marco Schinkel:
> Hello,
>
> I experience some strange behavior with vdr and a plain full featured
> Technotrend Rev. 1.6 (no mods, no daughterboards, no usage of internal
> connectors):
>
> When running VDR (version 1.6.0-2/1.6.0) after a few days the live tv on
> the composite out goes away (only black picture visible). The menu
> however is perfectly workable (and I can see it on the composite out on
> top of a black picture).
>
> I use the newest available firmware and recent drivers from the v4l-dvb
> repository (using the v4l-dv-hg gentoo ebuild) on an 2.6.27.7 kernel.
>
> dmesg output occasionally has the following message:
>
> saa7146 (2) saa7146_i2c_writeout [irq]: timed out waiting for end of xfer
>
> There are no other problems on the system, so I assume that it is either
> a dvb driver/firmware thing, or a vdr bug.
>
> Starting a recording in vdr leads to an empty 001.vdr file. Restarting
> vdr does not help. Reloading the drivers usually helps but sometimes
> not. In this cases i have to powercycle the system. The problem exists
> no matter what card I use and on which position on the pci bus the card
> sits (I tried different cards, all ttpci 1.6 on 4 different slots on 3
> different pci busses). The problem even occured on my old mainboard
> occasionally. So it is definitely not a hardware defect. I assume the
> problem is not even related with the i2c timeout.
>
> Is this problem known? Is there a known workaround or even better a way
> to fix this?
>
>
> Best Regards,
>
>
> Marco Schinkel
>
>
>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Hello,

the same problem is here. I think that the issue is the PCI bus (Riser card 
flexiple). Is since version 1.6.0 more traffic to the FF card? Another reason 
is the LNB. I think that the contact ressistance from card to LNB is to high. 
I have test it with femon. STR: 60% SNR: 81% Is this ok?

Any other ideas?

Regards Jens.



More information about the vdr mailing list