[vdr] vdr 1.7.0 and lifeview pci trio(saa7134)

Jordi Moles jordi.moles at gmail.com
Sun Dec 14 13:22:57 CET 2008


hi,

i had tried many times to install vdr with no luck, but i found a 
tutorial on how to install vdr 1.7.0 on ubuntu-like systems, from source 
code. It was pretty straight forward, i didn't have any problem on 
compiling and installing everything.

I've got a lifeview trio pci card, saa7134, and ubuntu detected the card 
and loaded itself the modules saa7134, saa7134_alsa and saa7134_dvb. It 
works great with kaffeine, "out of the box"

However, i need your help trying to make vdr get to the card.

This tutorial says that i must install multiproto drivers.
So, i downloaded them and compiled vdr on that. I didn't run "make 
install" on the multiproto path. Should i use the multiproto drivers 
instead of the ones that come with the kernel? As far as i understand 
the tutorial said it was necessary for compiling, but not for running 
vdr. Correct me if i'm wrong.

So... everything is compiled without any problem and i run vdr like this:

*********
/usr/bin/vdr -c /etc/vdr -E /var/vdr -l 3 -P'xineliboutput -l none -r 
37890 -p' -u root
*********

on the other hand.... if i run "scan", i can find all the possible 
channels i get from the satellite.
I did this to get the "channels.conf" for vdr:

*********
scan -o vdr /home/servidor/.kde/share/apps/kaffeine/dvb-s/Astra-19.2E >> 
channels.conf
*********

which gave some results and then i put this file into the /etc/vdr path.

If then i look into the logs, i see this:

*************
Dec 14 01:08:49 jordimoles vdr: [1006] cTimeMs: using monotonic clock 
(resolution is 1 ns)
Dec 14 01:08:49 jordimoles vdr: [1006] VDR version 1.7.0 started
Dec 14 01:08:49 jordimoles vdr: [1006] switched to user 'root'
Dec 14 01:08:49 jordimoles vdr: [1006] codeset is 'UTF-8' - known
Dec 14 01:08:51 jordimoles vdr: [1006] found 23 locales in /usr/share/locale
Dec 14 01:08:51 jordimoles vdr: [1006] loading plugin: 
/usr/lib/vdr/plugins/libvdr-xineliboutput.so.1.7.0
Dec 14 01:08:51 jordimoles vdr: [1006] loading /etc/vdr/setup.conf
Dec 14 01:08:51 jordimoles vdr: [1006] loading /etc/vdr/sources.conf
Dec 14 01:08:51 jordimoles vdr: [1006] loading /etc/vdr/diseqc.conf
Dec 14 01:08:51 jordimoles vdr: [1006] loading /etc/vdr/channels.conf
Dec 14 01:08:51 jordimoles vdr: [1006] loading /etc/vdr/svdrphosts.conf
Dec 14 01:08:51 jordimoles vdr: [1006] loading /etc/vdr/keymacros.conf
Dec 14 01:08:51 jordimoles vdr: [1007] video directory scanner thread 
started (pid=1006, tid=1007)
Dec 14 01:08:51 jordimoles vdr: [1008] video directory scanner thread 
started (pid=1006, tid=1008)
Dec 14 01:08:51 jordimoles vdr: [1006] reading EPG data from /var/vdr
Dec 14 01:08:51 jordimoles vdr: [1006] probing /dev/dvb/adapter0/frontend0
Dec 14 01:08:51 jordimoles vdr: [1007] video directory scanner thread 
ended (pid=1006, tid=1007)
Dec 14 01:08:51 jordimoles vdr: [1008] video directory scanner thread 
ended (pid=1006, tid=1008)
Dec 14 01:08:52 jordimoles vdr: [1006] ERROR (dvbdevice.c,471): 
Operation not supported
Dec 14 01:08:52 jordimoles vdr: [1010] section handler thread started 
(pid=1006, tid=1010)
Dec 14 01:08:52 jordimoles vdr: [1006] found 1 video device
Dec 14 01:08:52 jordimoles vdr: [1006] initializing plugin: 
xineliboutput (1.0.90-cvs): X11/xine-lib output plugin
Dec 14 01:08:52 jordimoles vdr: [1006] [xine..put] cTimePts: 
clock_gettime(CLOCK_MONOTONIC): clock resolution 0 us
Dec 14 01:08:52 jordimoles vdr: [1006] [xine..put] cTimePts: using 
monotonic clock
Dec 14 01:08:52 jordimoles vdr: [1006] [xine..put] RTP SSRC: 0x24a224e1
Dec 14 01:08:52 jordimoles vdr: [1006] setting primary device to 2
Dec 14 01:08:52 jordimoles vdr: [1006] assuming manual start of VDR
Dec 14 01:08:52 jordimoles vdr: [1006] SVDRP listening on port 2001
Dec 14 01:08:52 jordimoles vdr: [1006] setting current skin to "sttng"
Dec 14 01:08:52 jordimoles vdr: [1006] loading 
/etc/vdr/themes/sttng-default.theme
Dec 14 01:08:52 jordimoles vdr: [1006] starting plugin: xineliboutput
Dec 14 01:08:52 jordimoles vdr: [1012] Remote decoder/display server 
(cXinelibServer) thread started (pid=1006, tid=1012)
Dec 14 01:08:52 jordimoles vdr: [1012] [xine..put] cXinelibServer 
priority set successful SCHED_RR 2 [1,99]
Dec 14 01:08:52 jordimoles vdr: [1012] [xine..put] Listening on port 37890
Dec 14 01:08:52 jordimoles vdr: [1012] [xine..put] Listening for UDP 
broadcasts on port 37890
Dec 14 01:08:52 jordimoles vdr: [1012] [discovery] BROADCAST: VDR 
xineliboutput DISCOVERY 1.0^M Server port: 37890^M Server version: 
xineliboutput-1.0.90-cvs^M ^M
Dec 14 01:08:52 jordimoles vdr: [1006] [xine..put] 
cXinelibDevice::StartDevice(): Device started
Dec 14 01:08:52 jordimoles vdr: [1013] KBD remote control thread started 
(pid=1006, tid=1013)
Dec 14 01:08:52 jordimoles vdr: [1006] remote control KBD - learning keys
Dec 14 01:09:02 jordimoles vdr: [1006] switching to channel 1
Dec 14 01:09:02 jordimoles vdr: [1006] info: Canal no disponible!
Dec 14 01:09:04 jordimoles vdr: [1006] switching to channel 1
Dec 14 01:09:04 jordimoles vdr: [1006] info: Canal no disponible!

*************

so... to me this means that can't get to the card. is this right? I 
can't tune "channel 1". Actually it can't open any channel. I'm trying 
only with FTA channels, so... there shouldn't be any problem with that.

if i run:

********
vdr-sxfe --video=xv --aspect=16:9 --fullscreen --width=1280 --height=720 
--nokbd --post=tvtime:method=Linear,cheap_mode=1,pulldown=0, 
use_progressive_frame_flag=1
********

vdr-sxfe starts without any error reported, but then it says, again, "no 
signal"


what am i doing wrong?

I would appreciate any light you could through on this. Should i go back 
to 1.6? I haven't tried any other version, actually. When i came to 
linux, kaffeine was already installed and working without effort. The 
first attempt with other software has been this vdr 1.7.0.

Thanks.



More information about the vdr mailing list