[vdr] Problem with VDR 1.5.14 and FF card version 2.1 card and channels with high bitrate

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Sun Feb 10 22:51:01 CET 2008


On 02/10/08 20:34, Magnus Andersson wrote:
> Klaus Schmidinger wrote:
>> Those Telenor channels are encrypted, so I'm afraid I can't test them.
>>
>> However, this may also be the reason for your problem. When VDR first switches
>> to an encrypted channel, it always does so in Transfer-Mode, so that it can
>> check whether the TS packets get decrypted. Once it knows that a channel can be
>> decrypted, it switches to it in direct live mode if you switch to it again.
>>
>> While in Transfer-Mode, the high data rate stream is read from the FF card
>> and sent back to it for replay. I assume this is too much load for the FF card.
>>
>> Try switching to the same channel again after some 15 seconds. Does it show
>> up ok then?
> 
> Yes it does. If I stay 15 seconds with bad picture and change to another
> channel and back it works. I have to do that every time I restart vdr on
> these channels. Is there a solution to this or do I have to buy new
> hardware for VDR 1.6.0? I like VDR as it is now because I do not have
> any HDTV channels or a LCD TV.
> Why does it work in version 1.4.7?

Version 1.4.7 simply switched to the encrypted channel and didn't check
whether it was actually decrypted.

Version 1.5 automatically selects a suitable CAM, and if there is more
than one CAM that claims to be able to decrypt a given channel, it needs
to check whether it actually can do so. Therefore it starts in Transfer-Mode,
which is apparently a problem on FF cards with high bandwith channels.

Too bad the CI standard is so broken...

Klaus



More information about the vdr mailing list