[vdr] [ANNOUNCE] DVB-S2 + H.264 support for VDR-1.5.12

Magnus Hörlin magnus at alefors.se
Thu Jan 3 18:40:39 CET 2008


Reinhard Nissl wrote:
> Hi,
>
> attached you'll find updated patches for VDR-1.5.12, which replace all
> formerly patches regarding this subject.
>
> The patch named *-dvbs2-* additionally adds DVB-S2 support to VDR
> (thanks to Marco Schlüßler) and requires to use the DVB drivers from the
> multi-proto tree (see URL below for further details).
>
> The other patch is without DVB-S2 support and therefore most suitable
> for DVB-C users.
>
> The patches have been extended to also include the recently released
> audioindexer patch. Furthermore, the field detection code for H.264 has
> been adopted to MPEG2, where the same issue (VDR's index.vdr addresses
> frame pictures, so an index entry must not be generated for the second
> field of a field picture pair) exists, though hardly used compared to H.264.
>
> Have a look at this page for more instructions on this concern:
>
> http://www.vdr-wiki.de/wiki/index.php/OpenSuSE_DVB-S2_-_Step_by_Step_Installationsanleitung_%28Achtung_Beta%29
>
> Bye.
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
>   
Hi. Big thanks to Reinhard, Manu, Claus and others who has made this 
possible. Using the old multiproto tree from 2007-10-25 I have SVT HD 
(swedish) working quite well with an S2-3200 on a 2.3GHz AMD BE-2400. My 
problem is that with that multiproto tree, VDR won't tune to any dvb-t 
channels on my nova-t 500. And with the latest multiproto tree dvb-t 
works but only unless I load the S2-3200 modules. If I do that VDR just 
hangs at startup saying nothing and doesn't answer on svdrp. Is there a 
way to debug this and see what's happening? Does anybody have any ideas 
about what's going on? If I remove the channels.conf vdr complains about 
that, so I know it's coming that far at least. There's no difference if 
I load any plugins or not.

Again, I have followed all steps on the wiki and h.264+dvb-s2 works with 
the old multiproto, both using vdr-1.5.10 with your "old" patch and on 
vdr-1.5.12 with the new one. I'm running this on the 2.6.22-14-generic 
kernel that ships with Ubuntu 7.10.

Keep up the good work,
/Magnus H




More information about the vdr mailing list