[vdr] [ANNOUNCE] VDR developer version 1.5.14

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Mon Jan 28 18:18:04 CET 2008


On 01/28/08 18:15, Klaus Schmidinger wrote:
> On 01/28/08 02:49, Manu Abraham wrote:
>> Ludwig Nussel wrote:
>>> Klaus Schmidinger wrote:
>>>> On 01/27/08 16:25, Ludwig Nussel wrote:
>>>>> Klaus Schmidinger wrote:
>>>>>> - Implemented handling of DVB-S2 (thanks to Marco Schlüßler and Reinhald Nissl
>>>>>>   for a patch that was used to implement this). VDR now requires the "multiproto"
>>>>>>   DVB driver, e.g. from http://jusst.de/hg/multiproto.
>>>>> Would it be possible to make that optional via compile time define? 
>>>> I guess so, but I'm not going to ;-)
>>>> This new driver appears to be stable enough now - at least I've
>>>> been using it for a few days now without problems.
>>> *sigh* messing with kernel stuff sucks. Does a vdr built with the
>>> multiproto headers at least also work on vanilla kernels ie stable
>>> dvb drivers? That way one would only need to use different headers
>>> for building vdr but no extra kernel modules at run time.
>>>
>> AFAICT, the updated headers can be used along with the old drivers without
>> any issues. If not there's an issue with regards to backward compatibility.
>> Can you pleas point out the errors that which you see, when you are using
>> the updated headers and the old drivers ?
> 
> The new headers work fine with the old driver - if the application
> still uses the old API. I've tested that first thing before I switched
> to the new API.
> 
> However, I don't see how an application actually using the new API
> could work with the old driver.
> 
> At any rate, the patch from Ulrich Richter should work for people

Sorry, that should have been "Udo".

Klaus

> insisting to use the old driver.
> 
> Klaus



More information about the vdr mailing list