[vdr] vdr-1.6.0 channel not available

Tero Siironen izero79 at gmail.com
Sat May 3 18:22:52 CEST 2008


Klaus Schmidinger kirjoitti 3.5.2008 kello 19.06:

> On 05/03/08 16:24, Tero Siironen wrote:
>> Klaus Schmidinger kirjoitti 2.5.2008 kello 17.03:
>>
>>> On 04/27/08 12:49, Tero Siironen wrote:
>>>> ...
>>>> I don't know if this is same problem or not but I'm having similar
>>>> symptoms with one encrypted channel. With plain VDR 1.6.0 I cannot
>>>> tune
>>>> to that channel, while 1.4.7 works. As can be seen from the log,  
>>>> the
>>>> receiving starts from couple of seconds but stops right after  
>>>> giving
>>>> this channel not available message. My system has DVB-C 2.1 FF card
>>>> and
>>>> Satelco Easywatch budget card. All the other encrypted channels  
>>>> works
>>>> ok, but this one channel has problems with VDR 1.6.0.
>>>>
>>> Your CAM seems to "come and go".
>>> Please try the 1.6.0-1 maintenance patch from
>>>
>>>  ftp://ftp.cadsoft.de/vdr/Developer/vdr-1.6.0-1.diff
>>>
>>> which increases the time between the CAM status checks.
>>
>> Doesn't help, log is pretty similar still and picture shows now and
>> then for couple of seconds
>
> Looks like there are no more unexpected CAM resets, so the reason  
> for the
> "channel not available" must be something else. Maybe the CAM doesn't
> decrypt?
>
> You could add some debug output to cDevice::Action() to see whether
> the TS packets are getting descrambled. Maybe the  
> TS_SCRAMBLING_TIMEOUT
> needs to be increased.

I will try to debug it more. The same channel works with VDR 1.4.7 so  
the CAM works. Also with 1.6.0-1 all other encrypted channels that  
I've access works with that CAM, so there is something in that one  
channel which causes problems with 1.6.0-1. But I will report again  
when I get some more data.


-- 
Tero



More information about the vdr mailing list