[vdr] Compiling VDR on Linuxmce 0710 using Multiproto march revision

skerit at kipdola.com skerit at kipdola.com
Wed May 21 17:27:36 CEST 2008


Hello everyone,

I'm trying to install VDR on my linuxmce machine. There's a catch,  
though: I can only use the regular multiproto drivers from a few weeks  
ago since the new ones (and the multiproto plus driver) won't "detect"  
my DVB-S2 S2-3200 card.

The multiproto drivers I'm trying to use are a few months old, from  
march, and they're the only ones who will work. (I can use szap with  
them, anyway)

The problem is, when I try to compile VDR using this tutorial  
(http://www.vdr-wiki.de/wiki/index.php/OpenSUSE_VDR_DVB-S2_-_xine_-_Teil3) I  
get this error message:

         g++ -g -O2 -Wall -Woverloaded-virtual -Wno-parentheses -c  
-DREMOTE_KBD -DLIRC_DEVICE=\"/dev/lircd\" -DRCU_DEVICE=\"/dev/ttyS1\"  
-D_GNU_SOURCE -DVIDEODIR=\"/video\" -DCONFDIR=\"/video\"  
-DPLUGINDIR=\"./PLUGINS/lib\" -DLOCDIR=\"./locale\"  
-I/usr/include/freetype2 -I/opt/dvb/multiproto/linux/include dvbdevice.c
         dvbdevice.c: In member function ?bool cDvbTuner::SetFrontend()?:
         dvbdevice.c:302: error: ?DVBFE_SET_DELSYS? was not declared  
in this scope
         make: *** [dvbdevice.o] Error 1


Which I think indicates it's some kind of problem between VDR and the  
old drivers, is this correct? I pointed to the correct DVBDIR in the  
Make.config file so ...
How can I fix it?

Thank you for your time,

Jelle De Loecker

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.



More information about the vdr mailing list