[vdr] DVB API Wrapper for VDR 1.7.0

Udo Richter udo_richter at gmx.de
Fri May 23 14:30:43 CEST 2008


lucian orasanu wrote:
> I dont understend why are you kep mantaining this
> patch wen vdr-1.7.0 and all plugins should be evolving
> on multiproto. Stop releasing this patch, keep it for you!!

I think that there's a need for it. In my opinion something like VDR 
should work on any stable Linux distribution without requiring special 
kernels and drivers to be installed. I know that the goal is to push 
multiproto development, but intentionally forcing incompatibility to 
enforce people to upgrade their systems is not really typical for open 
source OSes, is it?

Lets do some optimistic timeline estimations: Multiproto is currently a 
fork of the off-kernel DVB drivers. Lets assume another half year til 
this is part of the main DVB drivers. Another half year to get it into 
stable kernels. This will surely be too late for Debain/Lenny for 
example, and VDR will not run on native Debian/Stable before around 
2011. This also means no more official Debian VDR packages newer than 
VDR 1.6.x until then.

Driver development will be pushed anyway, as DVB-S2 users need them. And 
there will be lots of them soon. But why force frequent kernel and 
driver updates to DVB-S/C/T users and even pure streaming clients, if 
they don't really need them?

VDR and plugins continue to evolve to multiproto anyway, the wrapper 
doesn't turn back time: VDR continues to internally use multiproto, the 
wrapper provides a 'fake' multiproto driver. And the new runtime 
detecting even allows transition: Just use the normal VDR binary package 
together with new drivers, and S2 works right out of the box! Fully 
support bleeding edge technology without spoiling old users! There's no 
way to make the switch to HD any easier than that.


Cheers,

Udo

PS: 151 downloads of API wrapper 0.3, and 19 downloads of API wrapper 
0.4 in the last 15 -mostly night- hours. No need for it?





More information about the vdr mailing list