[vdr] [PATCH] S2API for vdr-1.7.1 vanilla and extensions patch 64 ( 071020008 )

Martin Schlosser crypt at gmx.net
Tue Oct 14 19:36:47 CEST 2008


 > Hi All,
 >
 > this patches are for Steve Toth's repository at :
 > http://linuxtv.org/hg/~stoth/s2/ .
 > In theory they should work. I did them offline from my VDR.
 >
 > cu
 >
 > Edgar (gimli) Hucek

Hi,

I just can't compile my vdr. I applied the following patches to vanilla 
vdr-1.7.1:

- vdr-1.7.1_extensions.diff
- vdr-1.7.1-ext_h264.diff
- vdr-1.7.1-s2api-ext64.patch
- fix-s2api-dvbs-tuning.patch

Everything worked fine until here. Now I downloaded and installed S2API 
(from http://linuxtv.org/hg/~stoth/s2-mfe right?).

After setting the paths etc in teh make configs I tried to compile vdr, 
but this is what happens then:

root at HTPC:/usr/local/src/vdr-1.7.1# make
g++ -g -O2 -Wall -Woverloaded-virtual -Wno-parentheses -c 
-DUSE_CMDRECCMDI18N -DUSE_CMDSUBMENU -DUSE_CUTTIME -DUSE_DDEPGENTRY 
-DUSE_DOLBYINREC -DUSE_JUMPPLAY -DUSE_LIEMIKUUTIO -DUSE_PLUGINMISSING 
-DUSE_SETTIME -DUSE_WAREAGLEICON -DREMOTE_KBD -DVDR_USER=\"vdr\" 
-DLIRC_DEVICE=\"/dev/lircd\" -DRCU_DEVICE=\"/dev/ttyS1\" -D_GNU_SOURCE 
-DVIDEODIR=\"/daten/Video/vdr/video.00\" 
-DCONFDIR=\"/daten/Video/vdr/video.00\" -DPLUGINDIR=\"./PLUGINS/lib\" 
-DLOCDIR=\"./locale\" -DUSE_PLUGINAPI -I/usr/include/freetype2 
-I../s2-mfe/linux/include channels.c
channels.c:70: error: 'NBC_QPSK' was not declared in this scope
channels.c:71: error: '_8PSK' was not declared in this scope
channels.c:72: error: '_16APSK' was not declared in this scope
channels.c: In member function 'void 
cChannel::SetLinkChannels(cLinkChannels*)':
channels.c:690: warning: format not a string literal and no format arguments
make: *** [channels.o] Fehler 1


Any ideas?

Regards
Martin Schlosser



More information about the vdr mailing list