[vdr] Problem with some HD-channels. (xine-lib or xineliboutput ???)

Goga777 goga777 at bk.ru
Mon Sep 8 22:04:17 CEST 2008


Приветствую, Per

thanks for your sample
http://www.mellander.org/per/SD-Upscale-HD-SVT1-10mb.vdr

I tried to play it by ffplay/xine - everything is ok

but vdr 170 + xineliboutput couldn't play correctly it due to some errors


[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one

skip

[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]mmco: unref short failure
[h264 @ 0x8484170]mmco: unref short failure

skip

[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]non-existing PPS referenced
[h264 @ 0x8484170]decode_slice_header error
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8484170]mmco: unref short failure
Ошибка сегментирования


I think there is some problem with xine-lib-1.2 or xineliboutput


Goga




> I was running vdr-1.5.12 for quite som time, patched and with 
> multiprotodrivers + CoreAVC I was able to watch HD channels on Thor 
> 1.0W. The thing was that when I tried to watch:
> 
> SVT 
> HD;Telenor:11421:hC34M5S1Z35:S1.0W:25000:10512+512:640=sve;641=sve:0:B00:3801:70:14:0
> 
> I had problem with stuttering video and glitches in sound. The sound 
> glitches came every second and the video was a little bit more 
> stochastic in it's behaviour.
> 
> I really wanted to be able to watch this channel because it's one of the 
> 'official' swedish channels ( i.e Government owned ). I thought it was 
> because of lack of CPU-power, so I bought an eHD and installed vdr 
> 1.7.0. Everything was smooth as silk and I could watch almost all 
> HD-channels without any problem. No more underpowered CPU glitches or 
> crashes. Except for the SVT-channel that still had the problems noted 
> above. :(
> 
> So my question is, can anyone please tell me what special kind of stream 
> that SVT is using and what I can do with my installation to be able to 
> watch it? It's not FTA, but maybe someone could figure it out anyway. I 
> can upload a short recording if anybody want to take a look.




More information about the vdr mailing list