[vdr] Problem with some HD-channels. (xine-lib or xineliboutput ???)

hudo kkow 2manybills at gmail.com
Wed Sep 10 00:15:18 CEST 2008


On Mon, Sep 8, 2008 at 9:04 PM, Goga777 <goga777 at bk.ru> wrote:

> Приветствую, Per
>
> thanks for your sample
> http://www.mellander.org/per/SD-Upscale-HD-SVT1-10mb.vdr
>
> I tried to play it by ffplay/xine - everything is ok
>
> but vdr 170 + xineliboutput couldn't play correctly it due to some errors
>
>
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
>
> skip
>
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]mmco: unref short failure
> [h264 @ 0x8484170]mmco: unref short failure
>
> skip
>
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]non-existing PPS referenced
> [h264 @ 0x8484170]decode_slice_header error
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt
> input), discarding one
> [h264 @ 0x8484170]mmco: unref short failure
> Ошибка сегментирования
>
>
> I think there is some problem with xine-lib-1.2 or xineliboutput
>
>
> Goga
>


Hi, all.
I've already made a few remarks over this problem on
dvbn.happysat.orgforums. I've been able to reproduce the problem on
several channels
and satellites (Astra 19, Hotbird 13, Eurobird 9 and Hispasat 30). At the
time I've last tested it, it happened with all this combinations:

- vdr 1.7.0 + xine lib 1.2 + xine - log is as described above

- vdr 1.7.0 + xine lib 1.2 + xineliboutput - application exits with seg
fault the instant you start it (same problem, do)

- vdr1.7.0 + xine lib 1.2 + softdevice - log is as described above

AFAIK, it seems something on vdr or ffmpeg side. As you wrote on another
mail, stream played directly works ok.

Stay cool.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20080909/4343408c/attachment.htm 


More information about the vdr mailing list