[vdr] VDR 1.7.0 & S2API - Channels not Available

Morfsta morfsta at gmail.com
Wed Feb 4 11:41:27 CET 2009


>> The Multiproto channels.conf should be interchangeable with S2API. But
>> *some* modulation types didn't exist in S2API when I wrote the patches and
>> you need to check this for yourself. You need to check the settings (Red
>> button to edit in the TV Channels overview) and see if they are indeed
>> correct and change them accordinly. My best guess, is that the modulation
>> types are wrong.

Sorry to double post but as an update I removed all DVB-T channels and
then rescanned them using scan-s2 from
http://mercurial.intuxication.org/hg/scan-s2/.  It found all the
channels on my transmitter. Also DVB-S channels seem to be working
fine, not tried S2 yet.

The new format for DVB-T presented is: -

BBC ONE;BBC:730000:I999B8C34D34M16T2G32Y0:T:27500:600:601=eng,602=eng:0:0:4165:9018:4101:0

which is now accepted by VDR. However, I get a black screen when
tuning to them. In user.log I see: -

Feb  4 10:38:08 morfsta vdr: [18340] probing /dev/dvb/adapter0/frontend0
Feb  4 10:38:08 morfsta vdr: [18340] device 1 provides: DVBS DSS
Feb  4 10:38:08 morfsta vdr: [18344] tuner on device 1 thread started
(pid=18340, tid=18344)
Feb  4 10:38:08 morfsta vdr: [18345] section handler thread started
(pid=18340, tid=18345)
Feb  4 10:38:08 morfsta vdr: [18340] probing /dev/dvb/adapter1/frontend0
Feb  4 10:38:08 morfsta vdr: [18340] device 2 provides: DVBS DSS
Feb  4 10:38:08 morfsta vdr: [18347] tuner on device 2 thread started
(pid=18340, tid=18347)
Feb  4 10:38:08 morfsta vdr: [18348] section handler thread started
(pid=18340, tid=18348)
Feb  4 10:38:08 morfsta vdr: [18340] probing /dev/dvb/adapter2/frontend0
Feb  4 10:38:08 morfsta vdr: [18340] device 3 provides: DVBS DVBS2
Feb  4 10:38:08 morfsta vdr: [18340] device 3 forced to frontendType SYS_DVBS2
Feb  4 10:38:08 morfsta vdr: [18350] tuner on device 3 thread started
(pid=18340, tid=18350)
Feb  4 10:38:09 morfsta vdr: [18351] section handler thread started
(pid=18340, tid=18351)

which is funny  because devices 0 and 1 are DVB-T:

[   12.497993] DVB: registering adapter 0 frontend -858993460 (Philips
TDA10045H DVB-T)...
[   12.554597] DVB: registering adapter 1 frontend -858993460
(Conexant CX22702 DVB-T)...
[   12.594872] DVB: registering adapter 2 frontend 0 (Conexant
CX24116/CX24118)...

then when VDR starts tuning I see:

Feb  4 10:38:18 morfsta vdr: [18344] frontend 0 timed out while tuning
to channel 1, tp 642
Feb  4 10:39:18 morfsta vdr: [18347] frontend 1 timed out while tuning
to channel 1, tp 642
Feb  4 10:39:21 morfsta vdr: [18344] frontend 0 timed out while tuning
to channel 1, tp 642

Any suggestions?

Thanks



More information about the vdr mailing list