[vdr] why the VDR-PC can't auto run runvdr?

LinHai rcmodel8810 at hotmail.com
Wed Jan 14 02:48:54 CET 2009

My VDR system run on xorg without KDE.
cp init.d.runvdr.Debian /etc/init.d/runvdr
chmod a+x /etc/init.d/runvdr
cp runvdr /usr/bin/runvdr
chmod a+x /usr/bin/runvdr
cp runvdr.conf.example /etc/runvdr.conf
ln -s /etc/init.d/runvdr  /etc/rc2.d/S99runvdr
runvdr.conf:--------------------------------------------------# Fire up own X server as output deviceXSERVER="/usr/bin/X -nolisten tcp -config /etc/X11/xorg-runvdr.conf :0"--------------------------------------------------
when I start the VDR-PC,The Screen displays: /usr/bin/runvdr:line 576: 4515 Segmentation fault waiting for X server to shut downPID=4515RET=139VDR died within 10 seconds, this happened 6 time(s).Terminating because VDR died 6 times in a row quickly at wed Jan 14 06:51:28 CST 2009Sending 1 processes the TERM signal.terminated.
/usr/bin/runvdr:line 576: 4515 Segmentation fault-----------------------------------------------------# Act as a proxy for calling VDR, from within X sessionif [ -n "$XSERVERPROXY" ] ; then    eval "$VDRCMD &"    PID=$!    echo "PID $PID" > "$XSERVERPROXY"
    wait $PID #line 576: 4515 Segmentation fault
    echo "RET $?" >> "$XSERVERPROXY"    exit 0fi
But after I logined the VDR-PC.root at vdr:/etc/inti.d/runvdr startthe VDR-PC run X at first, next run vdr is OK.
why the VDR-PC can't auto run runvdr,but after I logined the VDR-PC,press the command:/etc/inti.d/runvdr start,the vdr running is OK?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20090114/f8d247a5/attachment.htm 

More information about the vdr mailing list