[vdr] [ANNOUNCE] vdr-xine-0.9.0 plugin

it's me ciaccom at hotmail.com
Wed Jan 21 10:39:56 CET 2009


>> Date: Mon, 12 Jan 2009 23:43:33 +0100
>> From: rnissl at gmx.de
>> To: vdr at linuxtv.org
>> Subject: [vdr] [ANNOUNCE] vdr-xine-0.9.0 plugin
>>
>> Hi,
>>
>> after being away 7 month from VDR development I'm pleased to
>> announce release 0.9.0. You can find it on my homepage as usual:
>>
>
> Welcome back - many people will be pleased about you beeing back to vdr! :)
>
>> Excerpt from HISTORY:
>>
>> 2009-01-12: Version 0.9.0
>>
> [..]
>> - Make use of new OSD functionality in xine-lib-1.2. For now
>> an OSD implementation must provide both new features to have
>> vdr-xine make use of it.
>> - Extended OSD support in xine-lib-1.2 to allow truecolor OSDs
>> as well as hardware scaled OSDs. The new functionality is
>> currently only provided by VDPAU enabled installations.
>
> Maybe a little bit OT, but i'm having a problem with compiling the latest xine-lib-1.2 HG. Earlier versions (last tested with xine-lib-1.2 from 2008-08-18) didn't show this effect. I'm compiling the libs as you suggested in this post: http://www.linuxtv.org/pipermail/vdr/2008-March/016195.html . Before i patched the sources with the xine-lib-1.2 vdpau patch from here http://www.jusst.de/vdpau - patching worked very well!:
>
> so:
>
> ./autogen.sh noconfig
>
> in src-dir and
>
> CFLAGS='-g3 -O3 -fPIC -lm -mtune=k8 -pipe' ../xine-lib-1.2-hg-2009-01-13/configure --disable-debug --with-external-ffmpeg=/opt/src/vdr/VDR-download/DVB-S2/ffmpeg-svn-2009-01-13 --disable-dxr3
>
> in build directory. "configure" worked well, but with make i'm getting:
>
> .
> .
> make[1]: Leaving directory `/opt/src/download/xine-vdpau/xine-0.9.0/build-ciax/po'
> Making all in misc
>
> make[1]: Entering directory `/opt/src/download/xine-vdpau/xine-0.9.0/build-ciax/misc'
>
> gcc -DHAVE_CONFIG_H -I. -I../include -I../../xine-lib-1.2-hg-2009-01-13/misc -I../../xine-lib-1.2-hg-2009-01-13 -I../include
> -I../../xine-lib-1.2-hg-2009-01-13/include -I../../xine-lib-1.2-hg-2009-01-13/src -I../src/xine-engine -I../../xine-lib-1.2-hg-2009-01-13/src/xine-engine
> -I../../xine-lib-1.2-hg-2009-01-13/src/xine-utils -I../src/input -I../../xine-lib-1.2-hg-2009-01-13/src/input
> -I../lib -I../../xine-lib-1.2-hg-2009-01-13/lib -DNDEBUG -D_REENTRANT -DXINE_COMPILE -pipe -Wall -Wformat=2 -Wno-format-zero-length
> -Wmissing-format-attribute -Werror-implicit-function-declaration -Wstrict-aliasing=2 -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes
> -Wwrite-strings -Wpointer-arith -g -g3 -O3 -fPIC -lm -mtune=k8 -pipe -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations
> -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration
> -MT xine-list.o -MD -MP -MF .deps/xine-list.Tpo -c -o xine-list.o ../../xine-lib-1.2-hg-2009-01-13/misc/xine-list.c
> cc1: error: unrecognized command line option "-Werror=implicit-function-declaration"
> make[1]: *** [xine-list.o] Error 1
> make[1]: Leaving directory `/opt/src/download/xine-vdpau/xine-0.9.0/build-ciax/misc'
> make: *** [all-recursive] Error 1
>
>
> "configure" also returned a line "checking if gcc supports -Werror=implicit-function-declaration flag... (cached) yes".
>
>
> i'm using kernel 2.6.26.5 on an AMD64 x86_64 platform with
>
> gcc -v
> Using built-in specs.
> Target: x86_64-linux-gnu
> Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --with-gxx-include-dir=/usr/include/c++/4.1.3 --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release x86_64-linux-gnu
> Thread model: posix
> gcc version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)
>
>
>
> Any pursuing hints would be very gratifying!
>
> ciax

hello, just to close up this specific compiling problem - my gcc version was to old! now, with version 4.3.2 xine-lib-1.2 and xine-0.9.0 builds fine!

greets, ciax

_________________________________________________________________
Teste jetzt die neue Windows Live Messenger Beta!
http://download.live.com/


More information about the vdr mailing list