[vdr] S2API wrapper patch 0.5 for VDR-1.7.4

Udo Richter udo_richter at gmx.de
Mon Jan 26 00:07:16 CET 2009


Hi list,


The new S2API-Wrapper patch for VDR-1.7.4 is ready. Beside adding 
support for the final 2G-flag, the patch also reverts the change that 
sends TS data directly to the device, since TS playback support is even 
newer than S2API support.

Since TS to PES conversion by VDR-1.7.4 is also broken, its a good idea 
to also apply the PlayTS [1] patch.

[1] http://www.linuxtv.org/pipermail/vdr/2009-January/019398.html


Behavior can be configured in Make.config again:

DEFINES += -DDVB_S2API_RUNTIME=1
    enables the runtime detection (default) (NOT YET WORKING!)

DEFINES += -DDVB_S2API_RUNTIME=0
    disables the runtime detection

DEFINES += -DDVB_S2API_WRAPPER=1
    enables the API wrapper (default on old DVB headers
    and if runtime detection is enabled)

DEFINES += -DDVB_S2API_WRAPPER=0
    disables wrapper and runtime detection. Can be used
    to compile S2API without proper DVB headers.
    (default on new DVB headers and runtime detection disabled)


Auto-detection will be back as soon as I know of a working mechanism to 
detect the presence of S2API drivers.


Get it:
http://www.udo-richter.de/vdr/patches.en.html#dvb-api-wrapper
http://www.udo-richter.de/vdr/patches.html#dvb-api-wrapper


Cheers,

Udo





More information about the vdr mailing list