[vdr] Black screen on some channels with vdr 1.7.6

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Tue May 5 09:30:51 CEST 2009


On 05/05/09 00:04, Ales Jurik wrote:
> On Monday 04 of May 2009, Klaus Schmidinger wrote:
>> On 04.05.2009 23:05, Marek Hajduk wrote:
>>> It's a pity, no answer.
>>> I would like to note, that with vdr 1.7.7 is result same-NO video but
>>> audio is OK. Receiving these channels with sat boxes like dreambox or
>>> triple dragon is without problem.
>> '1' is not a known video stream type in VDR.
>>
>> Try '2' or '27', as in
>>
>> AXN,AXN;UPC
>> Direct:10921:hC56M2O0S0:S19.2E:22000:651=2:660=hun,661=cze,662=eng:0:D02,18
>> 15:20352:1:1063:0
>>
>> or
>>
>> AXN,AXN;UPC
>> Direct:10921:hC56M2O0S0:S19.2E:22000:651=27:660=hun,661=cze,662=eng:0:D02,1
>> 815:20352:1:1063:0
>>
>> Klaus
> 
> Many thanks, it seems to works (with type of 2), but it is necessary to  
> set "Update channels" to "no". 

Please try this:

--- remux.c     2009/05/03 14:43:25     2.20
+++ remux.c     2009/05/05 07:27:21
@@ -795,6 +795,7 @@
                   scanner <<= 8;
                   scanner |= Data[i];
                   switch (type) {
+                    case 0x01: // MPEG 1 video
                     case 0x02: // MPEG 2 video
                          if (scanner == 0x00000100) { // Picture Start Code
                             if (synced && Processed)

With this you should be able to turn "Update channels" on again.

Klaus



More information about the vdr mailing list