[vdr] [ANNOUNCE] VDR developer version 1.7.5

Timothy D. Lenz tlenz at vorgon.com
Wed May 20 00:35:18 CEST 2009


I just got an updated v4l today because it has fixes for xc5000 based cards as of monday along with new firmware for that card. I
also use nexus and the first patch below seems to now be included, but the second patch uas a lot of both succeeded and failed:

patching file linux/drivers/media/dvb/ttpci/av7110.h
patching file linux/drivers/media/dvb/ttpci/av7110_av.c
Hunk #2 succeeded at 972 (offset 3 lines).
Hunk #3 succeeded at 985 (offset 3 lines).
Hunk #4 succeeded at 1022 (offset 3 lines).
Hunk #5 succeeded at 1034 (offset 3 lines).
Hunk #6 succeeded at 1128 (offset 3 lines).
Hunk #7 succeeded at 1140 (offset 3 lines).
Hunk #8 FAILED at 1153.
Hunk #9 succeeded at 1168 (offset 2 lines).
Hunk #10 succeeded at 1180 (offset 2 lines).
Hunk #11 succeeded at 1258 (offset -2 lines).
Hunk #12 succeeded at 1273 with fuzz 2 (offset -2 lines).
Hunk #13 FAILED at 1321.
Hunk #14 succeeded at 1347 (offset -2 lines).
Hunk #15 succeeded at 1357 (offset -2 lines).
Hunk #16 succeeded at 1371 (offset -2 lines).
Hunk #17 FAILED at 1469.
Hunk #18 FAILED at 1480.
4 out of 18 hunks FAILED -- saving rejects to file linux/drivers/media/dvb/ttpci/av7110_av.c.rej

Is it still needed or has it been replaced with another patch?

----- Original Message ----- 
From: "Klaus Schmidinger" <Klaus.Schmidinger at cadsoft.de>
To: <vdr at linuxtv.org>
Sent: Sunday, April 12, 2009 2:39 AM
Subject: [vdr] [ANNOUNCE] VDR developer version 1.7.5


IMPORTANT:
==========

You need the DVB driver version from

  http://linuxtv.org/hg/~endriss/v4l-dvb

or, alternatively, apply the two patches

  http://linuxtv.org/hg/~endriss/v4l-dvb/raw-rev/55fa4f709cf2
  http://linuxtv.org/hg/~endriss/v4l-dvb/raw-rev/b5567f27fba7

(in *this* sequence) in order to replay TS recordings with full featured
DVB cards! The second patch is only required for replaying pure audio
recordings.
Users of full featured DVB cards also need to use a new firmware,
available at

  http://www.escape-edv.de/endriss/firmware

Note that the header files in the latest driver versions may be broken.
If you get compiler error messages like

  /usr/include/sys/types.h:52: error: conflicting declaration 'typedef __ino64_t ino_t'
  /usr/include/linux/types.h:14: error: 'ino_t' has a previous declaration as 'typedef __kernel_ino_t ino_t'

when compiling VDR, you need to put the driver header files back to
how they were before they got broken. One way of doing this is to
apply the patch from

  ftp://ftp.cadsoft.de/vdr/Developer/v4l-dvb-header-fix.diff

(I'm not claiming that this is the right way to fix this, since the driver
developers may have had good reasons for making that change. However, both
the driver and VDR compile and work fine with this).




More information about the vdr mailing list