[vdr] Problems compiling xine-lib-1.2 for vdr-xine

Simon Baxter linuxtv at nzbaxters.com
Sun Oct 11 00:42:30 CEST 2009


>>> You must have picked up that revision number from a wrong place, since 
>>> the current revision is 20199. libavcodec/avcodec.h is the file where 
>>> you should look for the missing member definition. Also make sure that 
>>> the headers for that revision are the only ones installed. Most likely 
>>> you are not using correct headers.

Yes - my mistake.  Am running revision 20195

>> /usr/src/development/ffmpeg/libavcodec/avcodec.h       _does define_ int 
>> ticks_per_frame;
>>
>> Perhaps I am using the wrong headers - how do I link to these?
>
> You should install the headers (well, doing "make install" should do 
> that). Look for avcodec.h under /usr/local/include and check the contents 
> of that file. Also make sure that there is only one such file. To do that, 
> you could clear all ffmpeg headers and re-install the current ones.

Found 2 copies of the headers:
/usr/local/include/libavcodec/avcodec.h
/usr/include/ffmpeg/libavcodec/avcodec.h

Have written over the "/usr/include/ffmpeg/libavcodec/avcodec.h" with the 
new headers and it now complies.


NEXT PROBLEM(s):
1) I gather I still need a xine front end for xine-0.9.1?  I've compiled and 
installed "xine-ui-cvs-20090412200000"
Correct?

2) I've compiled xine-0.9.1 plugin and started vdr.  But when I start xine 
with:
xine --verbose=2 -V vdpau -L --post vdr_video --post vdr_audio --post 
upmix_mono vdr:/tmp/vdr-xine/stream#demux:mpeg_pes
I get:
xine: error while loading shared libraries: libxine.so.2: cannot open shared 
object file: No such file or directory
But:
# locate libxine.so.2
/usr/local/lib/libxine.so.2
/usr/local/lib/libxine.so.2.0.0

What's wrong now?  Is the wrong front end to use?





More information about the vdr mailing list