[vdr] Problems compiling xine-lib-1.2 for vdr-xine

Simon Baxter linuxtv at nzbaxters.com
Tue Oct 13 09:10:09 CEST 2009


> Found 2 copies of the headers:
> /usr/local/include/libavcodec/avcodec.h
> /usr/include/ffmpeg/libavcodec/avcodec.h
>
> Have written over the "/usr/include/ffmpeg/libavcodec/avcodec.h" with the 
> new headers and it now complies.

I did this because the YUM installed ffmpeg had loads of dependencies and 
wouldn't easily YUM REMOVE


> NEXT PROBLEM(s):
> 1) I gather I still need a xine front end for xine-0.9.1?  I've compiled 
> and installed "xine-ui-cvs-20090412200000"
> Correct?

I've ended up using the latest cvs xine-ui which works fine

> 2) I've compiled xine-0.9.1 plugin and started vdr.  But when I start xine 
> with:
> xine --verbose=2 -V vdpau -L --post vdr_video --post vdr_audio --post 
> upmix_mono vdr:/tmp/vdr-xine/stream#demux:mpeg_pes
> I get:
> xine: error while loading shared libraries: libxine.so.2: cannot open 
> shared object file: No such file or directory
> But:
> # locate libxine.so.2
> /usr/local/lib/libxine.so.2
> /usr/local/lib/libxine.so.2.0.0
>
> What's wrong now?  Is the wrong front end to use?

Idiot error - updated my /etc/ld.so.conf/xine.conf to add the location for 
these libraries, then did a ldconfig

AND....it works!!!

Not too happy about the CPU usage though - it's up at 55% on replaying MPEG2 
recordings, where xvmc/xxmc was at ~30ish.....

Ahh well! 




More information about the vdr mailing list