[vdr] VDR can no longer be compiled with the current driver from "http://linuxtv.org/hg/v4l-dvb".

Patrick Boettcher patrick.boettcher at desy.de
Thu Oct 22 10:10:03 CEST 2009



> On Sun, 2009-06-14 at 13:49 +0200, Klaus Schmidinger wrote:
> ...
>> If you use a full featured DVB card for replay you need the DVB driver
>> version from
>>
>>   http://linuxtv.org/hg/v4l-dvb
> 
> The driver had its API version changed on 2009-10-19 17:08:05:
> 
> --- v4l-dvb-af3d28c7ef19/linux/include/linux/dvb/version.h      2009-06-21 
> 02:25:44.000000000 +0200
> +++ v4l-dvb-f6680fa8e7ec/linux/include/linux/dvb/version.h      2009-10-19 
> 17:08:05.000000000 +0200
> @@ -24,6 +24,6 @@
> #define _DVBVERSION_H_
> 
> #define DVB_API_VERSION 5
> -#define DVB_API_VERSION_MINOR 0
> +#define DVB_API_VERSION_MINOR 1
> 
> #endif /*_DVBVERSION_H_*/

This modification was done due to the introduction of ISDB-T and ISDB-Tsb to 
the API.

Normally, in the sense of only being a human being doing lots of mistakes, the 
API is completely backward and binary compatible. Except for this 
minor-version-change.

If there was a mistake and it's not compatible, we still can fix it, as kernel 
2.6.32 is not yet out.

best regards,
--

Patrick Boettcher - Kernel Labs
http://www.kernellabs.com/



More information about the vdr mailing list