[vdr] 1.7.12 w/ FF card on old Linux + S2API wrapper

VDR User user.vdr at gmail.com
Mon Feb 1 00:29:22 CET 2010


On Sun, Jan 31, 2010 at 1:01 PM, Gavin Hamill <gdh at acentral.co.uk> wrote:
> I've been using the same 1.4.7 setup for over 2 years and thought I'd
> dip my toe in the 1.7.x world. I'm using Ubuntu dapper (mid 2006) so my
> DVB kernel/header setup is still at API level 3, hence I've been using
> Udo Richter's S2API wrapper.

While your system may work for years without updating it, eventually
you will fall too far behind and either need to update everything or
butcher the hell out of your source with patches that may or may not
work properly.  Lots of guys grumble about everything they need to
update when they finally decide to get out of the dark ages, and I can
never understand why they expect it to be any different.  At some
point, all the time & effort wasted on backwards compatibility winds
up only serving a very small handful of guys that seems to get joy
from telling people how long it's been since they've updated their
system.  My motto is stay at least remotely current or get left in the
dust.  ;)

If you're using a v4l tree that works with both your kernel and the
S2API wrapper, then you may want to try a VDR version prior to the FF
specific stuff being moved into a plugin and see if you have any
better luck.  I could be wrong but I think the FF change may not be
100% yet.

Good luck!



More information about the vdr mailing list