[vdr] xine-plugin and vdpau

Petri Helin phelin at googlemail.com
Sat Jan 23 11:22:41 CET 2010


On Sat, Jan 23, 2010 at 11:59 AM, Jussi J <vdr at jjussi.com> wrote:
> Hi!
> I have "nVidia Corporation G96 [GeForce 9400 GT] (rev a1)" what is VDPAU
> capable. I have loaded xine-plugin and try to use vdr-sxfe in vdpau mode,
> but no success..

AFAIK xine-plugin normally refers to vdr-xine, but I think you mean
xineliboutput, since you also mention vdr-sxfe.

>
> Any ideas where problem lies?

Check the following:

1. Make sure you have a xine-lib which supports vdpau. Since you seem
to be using xine-lib 1.2, it might be best to get the current hg in
case you haven't yet.

2. Make sure you have everything installed from nvidia drivers pov.
The simplest choice is to install manually the driver which nvidia
provides on their web page. But if you use a distribution package,
make sure you install the vdpau library as well.

3. Check that you have configured xineliboutput with vdpau enabled.

If you do all of the above steps properly, you should have no problems
with vdpau.

-Petri



More information about the vdr mailing list