[vdr] Xine - VDpau config help

Jouni Karvo Jouni.Karvo at iki.fi
Sat Jun 12 17:23:50 CEST 2010


hi,

I have Nvidia GT220, with xine-lib-1.2 from today.

I have been struggling with the deinterlacing of HD content, with no 
success.

My current settings in .xine/config (which I found by reading the source 
code - is there any documentation anywhere?):

video.output.vdpau_honor_progressive:1
video.output.vdpau_sd_deinterlace_method:temporal_spatial
video.output.vdpau_hd_deinterlace_method:temporal_spatial
video.output.vdpau_scaling_quality:1
video.output.vdpau_enable_inverse_telecine:1
video.output.vdpau_skip_chroma_deinterlace:0
video.output.vdpau_studio_levels:1

and here the output of xine, when trying to play HD content:

vdpau_set_property: property=0, value=1
vo_vdpau: deinterlace: temporal_spatial
vdpau_set_property: property=0, value=0
vo_vdpau: deinterlace: none
load_plugins: plugin vdpau_h264 will be used for video streamtype 4d.
Allocate 4 reference frames
vdpau_set_property: property=0, value=1
vo_vdpau: deinterlace: temporal_spatial
Create decoder: vdp_device: 1, profile: 7, res: 1920x1080
V]buffered 14.4 frames (v:36.3, a:14.4)
set_speed 1000000
vdr_video: osd: (0, 0)-(1920, 1080)@1.77778
video jump
vdpau_set_property: property=8, value=100
vdpau_set_property: property=13, value=100
frame: (0, 0)-(1920, 1080), zoom: (1.00, 1.00)
frame: (0, 0)-(1920, 1080), zoom: (1.00, 1.00)
vdr: osdflush: n: 1, 10.1, timeout: 0, result: 0
vo_vdpau: deinterlace: temporal
vo_vdpau: set_scaling_level=1
vo_vdpau: enabled features: inverse_telecine=1
vo_vdpau: disable noise reduction.
vo_vdpau: disable sharpness.
vo_vdpau: vdpau_update_csc: hue=0.000000, saturation=1.000000, 
contrast=1.000000, brightness=0.000000, color_standard=1
vo_vdpau: skip_chroma = 0

It seems from the messages that there would be deinterlacing, but 
nevertheless, when large objects move horizontally fast, they are striped.

Any ideas on where to go next?

yours,
         Jouni



More information about the vdr mailing list