[vdr] dpkg-gencontrol: error: the Depends field contains an arch-specific

Timothy D. Lenz tlenz at vorgon.com
Wed Jun 16 07:51:44 CEST 2010


Tried to do mk-build-deps on hg xine-1.2 running Debian Squeeze x64 on 
an Athlon64 x2 and got this error:

vorg at x64VDR:/usr/local/src/xine/xine-lib-1.2$ mk-build-deps
dh_testdir
dh_testroot
dh_clean -k
dh_clean: Compatibility levels before 5 are deprecated.
dh_testdir
dh_testroot
dh_install
dh_install: Compatibility levels before 5 are deprecated.
dh_installdocs
dh_installdocs: Compatibility levels before 5 are deprecated.
dh_installchangelogs
dh_installchangelogs: Compatibility levels before 5 are deprecated.
dh_compress
dh_compress: Compatibility levels before 5 are deprecated.
dh_fixperms
dh_fixperms: Compatibility levels before 5 are deprecated.
dh_installdeb
dh_installdeb: Compatibility levels before 5 are deprecated.
dh_gencontrol
dh_gencontrol: Compatibility levels before 5 are deprecated.
dpkg-gencontrol: error: the Depends field contains an arch-specific 
dependency but the package is architecture all
dh_gencontrol: dpkg-gencontrol -ldebian/changelog 
-Tdebian/xine-lib-1.2-build-deps.substvars 
-Pdebian/xine-lib-1.2-build-deps returned exit code 255
make: *** [binary-arch] Error 9
Error in the build process: exit status 2
cannot remove path when cwd is 
/usr/local/src/xine/xine-lib-1.2/equivs.rVZzcO for 
/usr/local/src/xine/xine-lib-1.2/equivs.rVZzcO:  at 
/usr/share/perl/5.10/File/Temp.pm line 902



More information about the vdr mailing list