[vdr] Xine plugins and LATM AAC audio (was Re: vdr 1.7.15 & eHD & French HD DTV)

Luis Fernandes telping at gmail.com
Wed Jun 23 12:54:04 CEST 2010


2010/6/23 Jonas Bardino <jonas at bardinosen.dk>:
> Bjørnar Nilsen wrote:
>> Den 22.06.2010 07:21, skrev ECLiPSE:
>>> I know that is not directly related to vdr, as my problem should come
>>> from the reel src and not vdr.
>>> I know there is here a good community of developpers and perhaps
>>> someone can look at the src of the hdplayer and see if it could be
>>> possible to add the detection of e-ac3 audio format , (and perhaps
>>> finding the way to decode it or at least enable the ac3 compatibility?).
>>
>> I have this problem on norwegian terrestrial channels, getting no audio.
>> I have just upgraded to vdr-1.7.15(yavdr 0.2.0). Im using xineliboutput.
>> Have used this ppa https://launchpad.net/~yavdr/+archive/unstable-vdr .
>>
>> Here are the stats:
>>     -Audio through xineliboutput doesnt work
>>     -Audio through streamdev to vlc(windows 7) works.
>>     -Recording plays fine in vlc(windows 7), but not wiht xineliboutput.
>>     -Femon 1.7.7 does not detect this audio codec.
>>
>> I have made a recording, here is a sample http://www.nilux.com/2.ts .
>>
>> Dunno if its xineliboutput or vdr.
>>
>> Regards
>> Bjørnar Nilsen
>
> Hi Bjørnar
>
> (I changed the subject as I do not think it is directly related to the
> original issue).
>
> I'm no expert when it comes to the audio formats, but I have the same
> experience here in Denmark. AFAICT the problem is missing LATM AAC[1]
> decoding support in xine/ffmpeg/libfaad itself.
> Neither xineliboutput or xine plugins provide audio for our MPEG4
> channels, but I can connect mplayer or vlc to xineliboutput on port
> 37890 and get audio, so the core VDR components are not to blame. My
> ffmpeg says something about missing LATM support when playing your
> recording and my own:
> $ ffmpeg -i 2.ts
> FFmpeg version SVN-r23019-4:0.6~svn20100505-2yavdr1, Copyright (c)
> 2000-2010 the FFmpeg developers
>  built on Jun 14 2010 12:58:34 with gcc 4.4.3
>  configuration: --extra-version='4:0.6~svn20100505-2yavdr1'
> --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau
> --enable-bzlib --enable-libgsm --enable-libschroedinger
> --enable-libspeex --enable-libtheora --enable-libvorbis
> --enable-pthreads --enable-zlib --disable-stripping
> --enable-runtime-cpudetect --enable-gpl --enable-postproc
> --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
>  libavutil     50.15. 0 / 50.15. 0
>  libavcodec    52.66. 0 / 52.66. 0
>  libavformat   52.62. 0 / 52.62. 0
>  libavdevice   52. 2. 0 / 52. 2. 0
>  libavfilter    1.19. 0 /  1.19. 0
>  libswscale     0.10. 0 /  0.10. 0
>  libpostproc   51. 2. 0 / 51. 2. 0
> [mpegts @ 0x14a7420]AAC LATM not currently supported, patch welcome
> [h264 @ 0x14abae0]number of reference frames exceeds max (probably
> corrupt input), discarding one
>    Last message repeated 361 times
> [mpegts @ 0x14a7420]max_analyze_duration reached
> Input #0, mpegts, from '2.ts':
>  Duration: 00:00:22.22, start: 14142.519600, bitrate: 7256 kb/s
>  Program 132
>    Stream #0.0[0x200]: Video: h264, yuv420p, 1280x720 [PAR 1:1 DAR
> 16:9], 50 fps, 50 tbr, 90k tbn, 100 tbc
>    Stream #0.1[0x280](nor): Data: 0x0011
>    Stream #0.2[0x258](nor): Subtitle: dvbsub
>    Stream #0.3[0x259](nor): Subtitle: dvbsub
>    Stream #0.4[0x240]: Data: 0x0006
>
> If you run xine --verbose=2 on the recording or on the xineliboutput
> stream you will similarly see libfaad errors from the failed audio decoding.
>
> I have experimented with a Personal Package Archive at Launchpad[2] to
> do some further testing but my conclusion so far is that no combination
> of recent ffmpeg and xine versions support LATM. Other players like vlc,
> xbmc, mythtv and mplayer apparently include their own LATM
> parser/decoder before handing of the decoding of the raw AAC stream to
> libfaad.
>
> I also commented on the issue at the VDR portal[3], but with no solution
> so far.
> I anyone knows more about this issue I'm all ears!
>
> Cheers, Jonas
>
> [1] http://wiki.multimedia.cx/index.php?title=Understanding_AAC
> [2] https://launchpad.net/~jonas-bardino
> [3] http://www.vdr-portal.de/board/thread.php?postid=912115
>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
>

hello, try to do as I did with svn xine-lib 1.2

read this
http://hg.debian.org/hg/xine-lib/xine-lib-1.2-vdpau/file/57d31b4ca5e0/contrib/README.contrib

and compile xine-lib with new sources of libfaad2 on contrib folder

http://www.audiocoding.com/faad2.html download from this site

is working with me to Portugal.

only on vdr-xineliboutput.

and yes Femon 1.7.7 does not detect this audio codec, this one must be
update like vdr-xine

hope that helps,

best regards.



More information about the vdr mailing list