[vdr] Recording DVB-T HD infrance

dplu dplu at free.fr
Mon Mar 15 22:10:02 CET 2010


Hi

There is a French forum who explain how to patch vdr to add support for e-ac3 
audio track on pat.c and remux.c

By default, the e-ac3 ID is not recognize by vdr ... this is why you have zero 
when you should have two available tracks

http://dvbkivabien2.info/viewtopic.php?f=30&t=13835

Best regards


Le Monday 15 March 2010 21:52:05 L. Hanisch, vous avez écrit :
> Hi,
>
> Am 15.03.2010 21:06, schrieb Eric Valette:
> > Hi list,
> >
> > I'm been fighting over Saturday to get vdr working on my netop (atom 330
> > + Ion) but I must admit I loose the battle. With debian vdr 1.6.0 SD TV
> > works fine but HD TV (TF1 HD, ARTE HD, FRANCE 2 HD, M6HD) channels
> > fails. Theses channels use mpeg4 for video + and eac3 (except ARTE HD)
> > for audio as described here
> > <http://www.digitalbitrate.com/dbr_hd.php?link=0&note=0&lang=fr> in
> > french
> >
> > I installed then vdr 1.7.13, and then got only the video stream but
> > still no audio. As I had similar problem with mplayer/xine and it was
> > fixed but manually editing the channels.conf (unfortunately not the same
> > format as vdr), I think I have the same kind of problem but can find a
> > way to correctly fix channels.conf.
> >
> > below are extract the working mplayer channels.conf and the
> > channels.conf generated w_scan used for vdr. Plus the mplayer info when
> > correctly decoding and playing the stream.
> >
> > Please CC when replying as I'm not suscribed
> >
> > --- working mplayer/xine/vlc
> > TF1
> > HD:602000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_64:TRAN
> >SMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:110+120:110+130:1281
> >
> > France 2
> > HD:602000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_64:TRAN
> >SMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:210+220:210+230:1282
> >
> > M6HD:602000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_AUTO:FEC_AUTO:QAM_64:TR
> >ANSMISSION_MODE_AUTO:GUARD_INTERVAL_AUTO:HIERARCHY_AUTO:310+320:310+330:12
> >83
> >
> >
> > ----- w_scan generated vdr channels.conf
> >
> > TF1 HD;MR5:602000:B8M64:T:27500:120=27:0:0:0:1281:8442:5:0
>
>   Try:
> TF1 HD;MR5:602000:B8M64:T:27500:120=27:0;130:0:0:1281:8442:5:0
>
>   Since it's ac3, the digital audio PID have to be set. The "analog audio"
> PID has to be 0, hence "0;130".
>
> Lars.
>
> > France 2 HD;MR5:602000:B8M64:T:27500:220=27:0:0:0:1282:8442:5:0
> > M6HD;MR5:602000:B8M64:T:27500:320=27:0:0:0:1283:8442:5:0
> >
> > -- here info about the stream by maplyer ----
> >
> > PROGRAM_ID=0 (0x00), PMT_PID: 16(0x10)
> > PROGRAM_ID=1281 (0x501), PMT_PID: 110(0x6E)
> > PROGRAM_ID=1282 (0x502), PMT_PID: 210(0xD2)
> > PROGRAM_ID=1283 (0x503), PMT_PID: 310(0x136)
> >
> > PROGRAM_ID=0 (0x00), PMT_PID: 16(0x10)
> > PROGRAM_ID=1281 (0x501), PMT_PID: 110(0x6E)
> > PROGRAM_ID=1282 (0x502), PMT_PID: 210(0xD2)
> > PROGRAM_ID=1283 (0x503), PMT_PID: 310(0x136)
> > VIDEO H264(pid=120) AUDIO A52(pid=130) NO SUBS (yet)! PROGRAM N. 1281
> > ID_VIDEO_ID=120
> > ID_AUDIO_ID=130
> > ID_AID_130_LANG=fra
> > PROGRAM_ID=0 (0x00), PMT_PID: 16(0x10)
> > PROGRAM_ID=1281 (0x501), PMT_PID: 110(0x6E)
> > PROGRAM_ID=1282 (0x502), PMT_PID: 210(0xD2)
> > PROGRAM_ID=1283 (0x503), PMT_PID: 310(0x136)
> > PROGRAM_ID=0 (0x00), PMT_PID: 16(0x10)
> > PROGRAM_ID=1281 (0x501), PMT_PID: 110(0x6E)
> > PROGRAM_ID=1282 (0x502), PMT_PID: 210(0xD2)
> > PROGRAM_ID=1283 (0x503), PMT_PID: 310(0x136)
> > PROGRAM_ID=0 (0x00), PMT_PID: 16(0x10)
> > PROGRAM_ID=1281 (0x501), PMT_PID: 110(0x6E)
> > PROGRAM_ID=1282 (0x502), PMT_PID: 210(0xD2)
> > PROGRAM_ID=1283 (0x503), PMT_PID: 310(0x136)
> > FPS seems to be: 25.000000
> > ID_FILENAME=dvb://TF1 HD
> > ID_DEMUXER=mpegts
> > ID_VIDEO_FORMAT=0x10000005
> > ID_VIDEO_BITRATE=0
> > ID_VIDEO_WIDTH=1440
> > ID_VIDEO_HEIGHT=1088
> > ID_VIDEO_FPS=25.000
> > ID_VIDEO_ASPECT=0.0000
> > ID_AUDIO_FORMAT=8192
> > ID_AUDIO_BITRATE=0
> > ID_AUDIO_RATE=0
> > ID_AUDIO_NCH=0
> > ID_LENGTH=0.00
> > ID_SEEKABLE=0
> > ID_CHAPTERS=0
> > Couldn't open video filter 'ass'.
> > ASS: cannot add video filter
> > [ass] Init
> > [ass] Updating font cache
> > =========================================================================
> >= Forced video codec: ffh264vdpau
> > Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
> > Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
> > =========================================================================
> >= ID_VIDEO_CODEC=ffh264vdpau
> > =========================================================================
> >= Forced audio codec: ffeac3
> > Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
> > AUDIO: 48000 Hz, 2 ch, s16le, 256.0 kbit/16.67% (ratio: 32000->192000)
> > ID_AUDIO_BITRATE=256000
> > ID_AUDIO_RATE=48000
> > ID_AUDIO_NCH=2
> > Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
> > =========================================================================
> >= AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
> > ID_AUDIO_CODEC=ffac3
> > [Mixer] No hardware mixing, inserting volume filter.
> > Starting playback...
> > PROGRAM_ID=0 (0x00), PMT_PID: 16(0x10)
> > PROGRAM_ID=1281 (0x501), PMT_PID: 110(0x6E)
> > PROGRAM_ID=1282 (0x502), PMT_PID: 210(0xD2)
> > PROGRAM_ID=1283 (0x503), PMT_PID: 310(0x136)
> > [VD_FFMPEG] Trying pixfmt=0.
> > Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
> > ID_VIDEO_ASPECT=1.7778
> > VO: [vdpau] 1440x1080 => 1920x1080 H.264 VDPAU acceleration
> > [VD_FFMPEG] XVMC-accelerated MPEG-2.
> >
> >
> >
> >
> > _______________________________________________
> > vdr mailing list
> > vdr at linuxtv.org
> > http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr




More information about the vdr mailing list