[vdr] Arabic language EPG is inappropriately displayed

semsem85 sami sami8519 at hotmail.com
Sun Sep 12 13:05:25 CEST 2010





> From: "Mr. Tux" 
> Subject: [vdr] Arabic language EPG is inappropriately displayed

> This will only build vdr, no plugins, no installation into the system
> It will just give you the idea if the patch still works
>
> This is basically my setup if I test new vdr stuff (patches, upgrades, etc)
>
> sudo aptitude install libfribidi-dev
> sudo apt-get build-dep vdr
>
> mkdir -v /usr/local/src/vdr
> cd /usr/local/src/vdr
>
> wget ftp://ftp.tvdr.de/vdr/Developer/vdr-1.7.15.tar.bz2
> tar -xvjf vdr-1.7.15.tar.bz2
>
> wget ftp://ftp.tvdr.de/vdr/Developer/vdr-1.7.0-bidi.diff.gz
> gunzip -d vdr-1.7.0-bidi.diff.gz
> sed 's/vdr-1.7.0.alrawab/vdr-1.7.15/g;s/vdr-1.7.0/vdr-1.7.15/g' \
> vdr-1.7.15-bidi.patch
> patch -b -p 0 -i vdr-1.7.15-bidi.patch
>
> cd vdr-1.7.15/
>
> make
> make plugins
>
> mkdir -pv $HOME/vdr-1.7.15/videos
>
> cp -vai *.conf $HOME/vdr-1.7.15/
> cp -vai runvdr.template $HOME/vdr-1.7.15/runvdr
>
>
> ## adjust runvdr:
>
> nano $HOME/vdr-1.7.15/runvdr
>
> export VDR_LANG="$LANG"
> export LC_COLLATE="$LANG"
> export VDR_CHARSET_OVERRIDE="ISO-8859-6"
>
> VDRPRG="/usr/local/src/vdr/vdr-1.7.15/vdr"
>
> VDROPTIONS="-w 60 --port=2001 --log=3 \
> --localedir=/usr/local/src/vdr/vdr-1.7.15/locale/ \
> --video=$HOME/vdr-1.7.15/videos --config=$HOME/vdr-1.7.15/ \
> --lib=/usr/local/src/vdr/vdr-1.7.15/PLUGINS/lib"
>
> # have a look @ syslog on a second terminal:
> tail -fn100 /var/log/syslog | grep vdr
>
> # now run vdr using the runvdr start script:
> sudo sh $HOME/vdr-1.7.15/runvdr
>
> #Replace CHANNEL with the channel you like to see
> # LSTE does list EPG data of that channel
>
> /usr/local/src/vdr/vdr-1.7.15/svdrpsend.pl -p 2001 -d localhost LSTE CHANNEL \
> | grep '215-' | cut -d - -f2- | sed -s '/^e/d;/^c/d'
>
>
> # stop vdr with "killall vdr" on another terminal
>
> The patch applies/builds fine after the path adjustment, don't know if it does
> what it's supposed to without arrabic channels to test...
> d

Hi,
Thanks for your help. I just want make sure if this does not make any conflicts with my installation of Yavdr 0.2. Because when I run the first command it says:

The following NEW packages will be installed:
  libfribidi-dev <+414kB>
The following packages will be REMOVED:
  libavcodec-unstripped-52{u} <-77.8kB>  libavdevice-extra-52{u} <-184kB>
  libavdevice-unstripped-52{u} <-77.8kB>
  libavformat-unstripped-52{u} <-77.8kB>
  libavutil-unstripped-49{u} <-77.8kB>  libdc1394-22{u} <-279kB>
  libpostproc-unstripped-51{u} <-77.8kB>
  libswscale-unstripped-0{u} <-77.8kB>  libusb-1.0-0{u} <-115kB>
  ttf-liberation{u} <-1,765kB>  vdr-plugin-avolctl{u} <-98.3kB>
  xbmc-skin-pm3-hd{u} <-176kB>
0 packages upgraded, 1 newly installed, 12 to remove and 0 not upgraded.
Need to get 76.9kB of archives. After unpacking 2,671kB will be freed.
Do you want to continue? [Y/n/?]



More information about the vdr mailing list