[vdr] AAC LATM audio issue on dvb-t israeli service

Barak Nahari naharib at gmail.com
Thu Aug 4 02:34:12 CEST 2011


I'm not a programmer but i've done some reading, trying to understand what
is wrong.

I've looked in the vdr source and found that vdr should be recognizing the
acc latm encoded audio, so the problem may not be in vdr.
http://git.gekrumbel.de/vdr.git?p=vdr.git;a=blob;f=remux.c;h=c3f07fb7074754446485ab10aa61e2e2a0b012a8;hb=bd61fee1e9328aec470c319494cccb90e53302c2

For what i understand the aac latm should have PID 0x11.
I've looked inside the vnsiserver source and didn't found any PID's only PES
PID's.
https://github.com/pipelka/vdr-plugin-vnsiserver/blob/7a964e109432ba00e8f9f7a4acdff5e217c08135/demuxer.h

I'm was a little confuse how to convert the PID to PES PID
So i've done a little googling and found this code
http://code.google.com/p/mediainfococoa/source/browse/trunk/Lib/MediaInfo/Multiple/File_MpegPs.cpp
it's seems that aac latm PES PID is 0xFA, unless i got it wrong, and i
didn't found this PES PID on the vnsiserver code.

I've tried to examine my ts file but couldn't export any info about the
audio track, only that the encoding is aac latm.
Is there is any more information regarding the audio track in my ts file?
http://www.2shared.com/file/wEdFKfZy/test.html

What should be my next step trying to understand where the problem?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.linuxtv.org/pipermail/vdr/attachments/20110804/80bcb79f/attachment.html>


More information about the vdr mailing list