[vdr] Unable to record 2 dvb-t channels

Marc vdr at ekass.net
Fri Nov 25 12:53:28 CET 2011


Hi,

I use vdr (1.7.21) with xvdr (git version). I can't record 2 channels,
vdr start the recording but the file is empty and after 30 seconds, vdr
throws an emergency exit :
Nov 25 12:18:34 myhost vdr: [12866] recording thread started (pid=10925,
tid=12866)
Nov 25 12:18:34 myhost vdr: [10949] XVDR: Recordings state changed (6)
Nov 25 12:18:34 myhost vdr: [10949] XVDR: Requesting clients to reload
recordings list
Nov 25 12:19:05 myhost vdr: [12866] ERROR: video data stream broken
Nov 25 12:19:05 myhost vdr: [12866] emergency exit request ignored
according to setup

When I try to watch these streams with xineliboutput, the stream starts
only after 30 seconds and I have only the sound :
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> DISCARD 114940568 61162
[19022] [demux_vdr] input->read_block() was interrupted
[19021] [input_vdr] <control> STILL 0
[19022] [input_vdr] <control> <data> DISCARD 114940568 61162
[19022] [input_vdr] wait_stream_sync: discard_index 114940568 != curpos
114869128 ! (diff 71440)
[19022] [input_vdr] wait_stream_sync: streams synced at 114940568/114940568
[19021] [input_vdr] <control> LIVE 0
[19022] [input_vdr] <control> <data> BLANK
prebuffer=14400 pts
[19021] [input_vdr] <control> STILL 0
vdpau_set_property: property=0, value=0
vo_vdpau: deinterlace: none
[19022] [input_vdr] wait_fifos_empty: video 0, audio 0
prebuffer=2000 pts
prebuffer=14400 pts
[19021] [input_vdr] <control> STILL 0
[19021] [input_vdr] <control> LIVE 1
prebuffer=14400 pts
[19021] [input_vdr] <control> TRICKSPEED 1
[19021] [input_vdr] <control> STILL 0
[19022] [demux_vdr] PAT: program changed, flushing demuxer
[19022] [demux_vdr] PMT changed, resetting demuxer
[19022] [demux_vdr] New PTS: 7327138046 (AUDIO)
[19022] [demux_vdr] audio stream changed: 00000000 -> 03010000
*** The stream  doesn't start
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> OSDCMD
*** After 30 seconds, the audio start but no picture

An example with an other channel of the same provider (France Television
Group, the 2 wrecked channels are from the same provider):
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> DISCARD 56596648 30119
[19022] [demux_vdr] input->read_block() was interrupted
[19021] [input_vdr] <control> STILL 0
[19021] [input_vdr] <control> LIVE 0
prebuffer=14400 pts
[19021] [input_vdr] <control> STILL 0
vdpau_set_property: property=0, value=0
vo_vdpau: deinterlace: none
[19022] [input_vdr] <control> <data> DISCARD 56596648 30119
[19022] [input_vdr] wait_stream_sync: streams synced at 56596648/56596648
[19022] [input_vdr] <control> <data> BLANK
[19022] [input_vdr] wait_fifos_empty: video 0, audio 0
prebuffer=2000 pts
prebuffer=14400 pts
[19021] [input_vdr] <control> STILL 0
[19021] [input_vdr] <control> LIVE 1
prebuffer=14400 pts
[19021] [input_vdr] <control> TRICKSPEED 1
[19021] [input_vdr] <control> STILL 0
[19022] [demux_vdr] PAT: program changed, flushing demuxer
[19022] [demux_vdr] PMT changed, resetting demuxer
[19022] [demux_vdr] New PTS: 6415996599 (VIDEO)
[19022] [demux_vdr] audio stream changed: 00000000 -> 03410000
[19021] [input_vdr] <control> HDMODE 1
[19021] [input_vdr] WARNING: xine-engine setting
"engine.buffers.video_num_frames":22 is too small for some HD channels
vdpau_set_property: property=0, value=1
vo_vdpau: deinterlace: temporal_spatial
Broken NAL, skip it.
ffmpeg_audio_dec: increasing buffer to 98304 to avoid overflow.
Allocate 4 reference frames
Create decoder: vdp_device: 1, profile: 8, res: 1920x1080
vo_vdpau: deinterlace: temporal
vo_vdpau: set_scaling_level=0
vo_vdpau: enabled features: inverse_telecine=1
vo_vdpau: disable noise reduction.
vo_vdpau: disable sharpness.
vo_vdpau: vdpau_update_csc: hue=0.000000, saturation=1.000000,
contrast=1.000000, brightness=0.000000, color_standard=1 studio_levels=0
vo_vdpau: skip_chroma = 0
vo_vdpau: background_color = 0
[19021] [input_vdr] <control> OSDCMD
[19021] [input_vdr] <control> OSDCMD

Regards,

Marc.



More information about the vdr mailing list