[vdr] [DISCUSSION REQUEST] reintroduce a common make configuration file in VDR-1.7.35

Marx acc.for.news at gmail.com
Fri Dec 28 14:25:03 CET 2012


I don't think arguing which userspace is bigger is so important.
I'm rather silent user and use VDR a few years now.
First I compiled it from scratch because there were no other option.
Then I tried to use packages but failed. Packages were outdated, only a 
few plugins in repository. No good decription how to compile those 
missing myself. Next I used eTobi packages (fits Debian distro), yaVDR 
packages (Ubuntu based but usable on Debian).
Now I use packages from Debian, compiling myself a few missing plugins 
and installing them manually.
I agree that "make;make install" is behind most of us, linux users. And 
I like this change. Hovewer I wouldn't bash those who still use it, it's 
linux freedom.
Personally I don't like digging /var/lib/vdr, /etc/default/vdr etc so I 
did symlinks to have all in one place, as it is in source installation. 
Hovewer I like running apt, U, g and after a while new VDR version is 
running with (almost) all plugins working.
And I think it's the way to go. Geek can clone repositories, patch and 
compile VDR and plugins himself. It's the man who will dig mailing list, 
who will ask question.
But casual user who needs only working application need stable working 
packages. He will not come here because he don't know what mailing list 
is. He probably doesn't know irc and will not create news account nor 
login to vdr portal (mainly in german language anyway).

I also disagree with pointing at 1.6 as a stable release.
Let's look at
ftp://ftp.tvdr.de/vdr/
vdr-1.6.0.tar.bz2 Mar 23  2008
Do you really suuggest to use software released more then 4 years old?
I understand that sometimes software isn't actively developed and so 
there is no developers to work on releases. Hovewer 1.7 is actively 
developed and has so many important changes that 1.6 is no longer usable.
I'm not criticizing lack of new stable release, it's Klaus choice. 
Hovewer you shoudln't criticize people who try to use developer version 
- they have no option to use stable one because there is no such version 
which can be used (1.6 doesn't work with HD, right?).

Marx




More information about the vdr mailing list