[vdr] HDMI output detection problems

Matti Horila mhorila at nic.fi
Mon Jul 30 19:01:41 CEST 2012


Hi,

Same problem here using Sony receiver and Octava hdmi splitter after receiver 
(for TV and projector)

On 28.7.2012 15:18, Jouni Karvo wrote:
> hi,
>
> since starting to use a AV receiver between TV and VDR, I have had HDMI
> detection problems.
>
> To start X server even when TV is not on, I use custom edid file that I got from
> the tuner.  With this, VDR always starts X properly, so even if VDR has
> auto-started for recording, the output works.

I tried all kind of custom edid files (read from receiver, tv, projector or 
splitter) none of the files solved negoatiation problems.

>
> Card: Nvidia GT220, vdr-xine plugin, Xorg, NAD receiver and Sony TV.
>
> If I start TV, though, for some reason, most often there is no negoatiation (or
> a failed one) between the receiver and VDR, so there will be no picture.
> Normally there is a sound, though. I have to switch the input selector of the
> receiver first to DVD input, then back to TV input to get the image.  If the
> tuner and TV are on when X server starts, the image appears correctly.
>
> Are there any flags in nvidia-settings or Xorg.conf or Xine configuration that
> would tell the graphics card to help the tuner to notice that there indeed is an
> image also on the HDMI cable?

I also tried various nvidia flags without luck. I did use custom script to put 
display to sleep mode (xset dpms force off) and then back on after small delay.

Nowdays i have programmable remote control which has support for macros, so it 
just changes receivers input to dvd and then back to vdr when powering on the 
system.

Regards,
Matti


>
> yours,
>          Jouni
>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
>




More information about the vdr mailing list