[vdr] VDR 1.7 FreeBSD segfault when cutting recordings

Gerhard Brauer gb+ML-2011 at derbrauer.homelinux.net
Fri Mar 15 10:54:04 CET 2013


Hello,

i'm new on this list and my English is not the best...

I'm using VDR 1.7 headless on a FreeBSD machine. Interaction with
this vdr server is done via vdr-sfxe from the xineliboutput plugin.

I never have any problem during other actions with the remote VDR
(recording, viewing, place cutting marks,...) _exept_ when i start
the cutting procedere itself with the keyboard shortcut "2".
Most times (> 95%) the remote vdr segfaults immidiatly. The file
structure is still created (%foobar ff.). In the few times when it
not segfaults then the cutting is done well without problems.

I have contacted the FreeBSD maintainer of the vdr port and he
advised to do a gdb backtrace on the generated coredump file. After
seeing the backtrace he has no solution and told me to post better
here on the list.
I attach the gdb backtrace output with this mail (i hope the
mailinglist allow attached file). Maybe you have a solution and/or
an idea how to solve this. Of course i could do further tests or
debugging, the segfault is well to reproduce here ;-)

Sometimes (but not so often and reproducable), when the cutting
process/thread is not segfaulting, i got also an dying vdr process
with signal 10 (bus error). That's when i use "backspace" to close
the well cutted recording, normally it would go back to the current
TV channel. Don't know if this is in some relation with the
segfault/signal 11 I often have. This rare error i also got only
during the cutting procedere, i could never reproduce it during
watching TV or recordings.

Some infos on hardware and software versions of the (vdr) server:
---------------------
FreeBSD 9.0-RELEASE-p3 amd64
CPU: AMD E-450 APU with Radeon(tm) HD Graphics (1699.36-MHz K8-class
CPU)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
real memory  = 8589934592 (8192 MB)
avail memory = 7809277952 (7447 MB)

Filesystem ZFS

vdr-1.7.29_2 
vdr-plugin-xineliboutput-1.0.90s20120511_6 
-----------------------
Log output when the vdr dies with signal 11 (this is not from the
attached backtrace):
Mar 15 10:44:00 s01 vdr: [50363392] setting audio track to 1 (0)
Mar 15 10:44:00 s01 vdr: [50364416] TS buffer on device 1 thread ended (pid=8844, tid=50364416)
Mar 15 10:44:00 s01 vdr: [50365440] buffer stats: 34404 (1%) used
Mar 15 10:44:00 s01 vdr: [50365440] receiver on device 1 thread ended (pid=8844, tid=50365440)
Mar 15 10:44:17 s01 vdr: [50361344] playing '/video/Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.48.50.99.rec/002.vdr'
Mar 15 10:44:19 s01 vdr: [50363392] SetBrokenLink: no GOP header found in video packet
Mar 15 10:44:31 s01 vdr: [50361344] loading /video/Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.48.50.99.rec//marks.vdr
Mar 15 10:44:31 s01 vdr: [50361344] creating directory /video/%Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.58.50.99.rec
Mar 15 10:44:31 s01 vdr: [50361344] removing /video/%Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.58.50.99.del/index.vdr
Mar 15 10:44:31 s01 vdr: [50361344] removing /video/%Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.58.50.99.del/001.vdr
Mar 15 10:44:31 s01 vdr: [50361344] removing /video/%Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.58.50.99.del/info.vdr
Mar 15 10:44:31 s01 vdr: [50361344] removing /video/%Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.58.50.99.del
Mar 15 10:44:31 s01 vdr: [50361344] loading /video/Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.48.50.99.rec//marks.vdr
Mar 15 10:44:31 s01 vdr: [50361344] playing '/video/Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.48.50.99.rec/001.vdr'
Mar 15 10:44:31 s01 vdr: [50361344] recording to '/video/%Die_Marx_Brothers_im_Kaufhaus/2012-10-29.01.58.50.99.rec/001.vdr'
Mar 15 10:44:31 s01 vdr: [58882048] video cutting thread started (pid=8844, tid=58882048)
Mar 15 10:44:32 s01 kernel: pid 8844 (vdr), uid 938: exited on signal 11 (core dumped)
-------------------------

>From my low experience (I'm not a C developer) i think it could be a thread
timing problem, maybe FreeBSD special and in relation with the ZFS filesystem.
Suspicios is IMHO that an error occurs only in the cutting procedere.

So, do you smell antyhing like a bug or similar ;-) Any ideas what i could do
or test/debug to get rid off this error?

Regards and TIA

        Gerhard

-------------- next part --------------
A non-text attachment was scrubbed...
Name: bt.txt.gz
Type: application/octet-stream
Size: 2563 bytes
Desc: not available
URL: <http://www.linuxtv.org/pipermail/vdr/attachments/20130315/d6f1296a/attachment.obj>


More information about the vdr mailing list