[vdr] [ANNOUNCE] S2API Wrapper Light 0.10 for VDR-2.0

Udo Richter udo_richter at gmx.de
Sun Mar 31 21:31:34 CEST 2013


Hi,

I've uploaded the newest version of S2API Wrapper 'light', the wrapper
patch to VDR that ensures DVB API compatibility to all DVB 5.0 API
kernel headers. The new version fixes the DVB-S2 EPG bug that was
introduced with 1.7.40, whenever the runtime kernel had DVB API 5.7 or less.

To do so, the wrapper queries the API version of the running kernel, and
switches to legacy code depending on that. At the same time, some of the
VDR compile-time code switches depending on DVB API version of the
kernel/driver headers were converted to runtime kernel switches.

All in all, with the patch VDR should compile on all DVB header versions
from 5.0 upwards, and all DVB features should be available as long as
the runtime kernel supports them.

Get it here:
http://www.udo-richter.de/vdr/patches.en.html#dvb-api-wrapper
http://www.udo-richter.de/vdr/patches.html#dvb-api-wrapper


Cheers,

Udo



More information about the vdr mailing list