[vdr] softhddevice and alsa dmixer

Poubelle fce.valeins at libertysurf.fr
Thu Feb 13 17:01:10 CET 2014


I would use the same xbmc softhddevice time . It works with the command:
svdrsend PLUG softhdevice ATTA
But I have a problem with the sound output. Softhddevice only supports 
ALSA therefore no possibility of using PULSEAUDIO .
I would like to share my SPDIF between XBMC and Softhddevice .

I run vdr with the following command line :

vdr -P'sofhddevice -v vdpau -v -a plughw : 0,1 '

My .asoundrc file :
pcm.dmixer {
   type dmix
   ipc_key 2048
   slave {
     pcm "hw:0,1" # Always use pure hw. dmix will reformat/resample audio.
     period_size 512 # If you get stuttering/or non-working audio, 
fiddle around with these
     buffer_size 4096
     rate 48000 # HDMI, I'll assume 48kHz
     format S16_LE # Should be default for pretty much any soundcard.
   }
   bindings {
     0 0
     1 1
   }
}

pcm.!default {
   type plug
   slave.pcm dmixer
}


My aplay -l output :
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: NVidia [HDA NVidia], périphérique 0: ALC1200 Analog [ALC1200 
Analog]
   Sous-périphériques: 1/1
   Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 1: ALC1200 Digital [ALC1200 
Digital]
   Sous-périphériques: 1/1
   Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
   Sous-périphériques: 1/1
   Sous-périphérique #0: subdevice #0

The options are tested:

XBMC SPDIF solfthddevice with -a plughw : 0.1 => XBMC OK, VDR no sound
XBMC Default , solfthddevice with -a plughw : 0,1 => XBMC no sound, VDR OK
XBMC Default ; solfthddevice with -a dmix => XBMC no sound, VDR OK

The only solution that works is :
XBMC SPDIF solfthddevice with -a plughw : 0,3 (HDMI) : OK XBMC , VDR OK

but the HDMI sound on my TV is bad, this is why I like to have 
everything on the SPDIF.

Senufo




More information about the vdr mailing list