[vdr] mp3 plugin for vdr-2.1.4

Peter Münster pmlists at free.fr
Thu Feb 13 22:36:11 CET 2014


Hi,

When compiling the mp3 plugin, I get this error:

--8<---------------cut here---------------start------------->8---
*** Plugin mp3:
WARNING: plugin mp3 is using an old Makefile!
g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE  -c -D_GNU_SOURCE -DAPIVERSNUM=20104 -DHAVE_SNDFILE -DHAVE_VORBISFILE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/vdr/soft/vdr-2.1.4/include decoder.c
decoder.c: In member function ‘bool cFileInfo::FileInfo(bool)’:
decoder.c:224:76: warning: format ‘%llx’ expects argument of type ‘long long unsigned int’, but argument 2 has type ‘__fsblkcnt64_t {aka long unsigned int}’ [-Wformat]
decoder.c:224:76: warning: format ‘%llx’ expects argument of type ‘long long unsigned int’, but argument 3 has type ‘__fsfilcnt64_t {aka long unsigned int}’ [-Wformat]
decoder.c: In member function ‘char* cInfoCache::CacheFile()’:
decoder.c:635:36: error: ‘VideoDirectory’ was not declared in this scope
decoder.c:636:1: warning: control reaches end of non-void function [-Wreturn-type]
make[1]: *** [decoder.o] Error 1
--8<---------------cut here---------------end--------------->8---

Could anybody help please to make the plugin work with the latest vdr
version?

Thanks in advance,
-- 
           Peter




More information about the vdr mailing list