<div dir="ltr"><br><br><div class="gmail_quote">On Mon, Sep 8, 2008 at 9:04 PM, Goga777 <span dir="ltr">&lt;<a href="mailto:goga777@bk.ru" target="_blank">goga777@bk.ru</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">


Приветствую, Per<br>
<br>
thanks for your sample<br>
<a href="http://www.mellander.org/per/SD-Upscale-HD-SVT1-10mb.vdr" target="_blank">http://www.mellander.org/per/SD-Upscale-HD-SVT1-10mb.vdr</a><br>
<br>
I tried to play it by ffplay/xine - everything is ok<br>
<br>
but vdr 170 + xineliboutput couldn&#39;t play correctly it due to some errors<br>
<br>
<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
<br>
skip<br>
<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
<br>
skip<br>
<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]non-existing PPS referenced<br>
[h264 @ 0x8484170]decode_slice_header error<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]number of reference frames exceeds max (probably corrupt input), discarding one<br>
[h264 @ 0x8484170]mmco: unref short failure<br>
Ошибка сегментирования<br>
<br>
<br>
I think there is some problem with xine-lib-1.2 or xineliboutput<br>
<br>
<br>
Goga<br>
</blockquote><div><br>&nbsp;</div></div>Hi, all.<br>I&#39;ve already made a few remarks over this problem on <a href="http://dvbn.happysat.org" target="_blank">dvbn.happysat.org</a> forums. I&#39;ve been able to reproduce the problem on several channels<br>


and satellites (Astra 19, Hotbird 13, Eurobird 9 and Hispasat 30). At the time I&#39;ve last tested it, it happened with all this combinations:<br><br>- vdr 1.7.0 + xine lib 1.2 + xine - log is as described above<br><br>

- vdr 1.7.0 + xine lib 1.2 + xineliboutput - application exits with seg fault the instant you start it (same problem, do)<br>
<br>- vdr1.7.0 + xine lib 1.2 + softdevice - log is as described above<br><br>AFAIK, it seems something on vdr or ffmpeg side. As you wrote on another mail, stream played directly works ok.<br><br>Stay cool.<br></div>