<div dir="ltr"><div class="gmail_quote">On Sun, Dec 7, 2008 at 3:06 PM, Klaus Schmidinger <span dir="ltr">&lt;<a href="mailto:Klaus.Schmidinger@cadsoft.de">Klaus.Schmidinger@cadsoft.de</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">On 07.12.2008 13:21, Klaus Schmidinger wrote:<br>&gt; Attached is an updated version of the patch to make VDR use<br>
&gt; the S2API. Dominik Strasser reported that he got log entries like<br>&gt;<br>&gt; &nbsp; Dec &nbsp;6 18:39:02 VDR vdr: [4102] ERROR: frontend 0: Das Argument ist ung├╝ltig<br>&gt; &nbsp; Dec &nbsp;6 18:39:02 VDR kernel: DVB: adapter 0 frontend 1935763502 symbol rate 0 out of range (451875..7230000)<br>
&gt;<br>&gt; and I now also get<br>&gt;<br>&gt; &nbsp; Dec &nbsp;7 13:03:26 vdr2 vdr: [3441] ERROR: frontend 0: Invalid argument<br>&gt; &nbsp; Dec &nbsp;7 13:03:26 vdr2 kernel: DVB: adapter 0 frontend 0 symbol rate 0 out of range (5000000..45000000)<br>
&gt;<br>&gt; when trying to tune to a DVB-S2 channel.<br>&gt;<br>&gt; The attached patch logs the value put into the DTV_SYMBOL_RATE slot,<br>&gt; and it appears to be fine. Why the value falls back to 0 when tuning<br>&gt; is currently totally unclear (as is the large frontend value in Dominik&#39;s<br>
&gt; case).<br>&gt;<br>&gt; Any help in debugging this would be appreciated.<br><br>Some more info: apparently the problem only happens if a DVB-S2 card<br>(a TT-budget S2 3200 in my case) is (attempted to be) tuned to a DVB-S2<br>
channel after the driver has been freshly loaded. Once the card has<br>been tuned to a DVB-S channel, subsequent tuning to DVB-S2 channels works fine.</blockquote>
<div>That scenario works fine with scan-s2 utility.</div>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid"><span id=""></span><br><br>Now I&#39;m unsure whether this is a VDR bug or a driver bug...</blockquote>
<div>Where is the origin of frontend value? I think its VDR internal and is not received from the driver...</div>
<div>&nbsp;</div>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid"><span id=""></span><br><br>Klaus<br><br>_______________________________________________<br>vdr mailing list<br>
<a href="mailto:vdr@linuxtv.org">vdr@linuxtv.org</a><br><a href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr" target="_blank">http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr</a><br></blockquote></div><br></div>