<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=iso-8859-1">
<META content="MSHTML 6.00.2800.1491" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT face=Arial size=2>Debian</FONT></DIV>
<BLOCKQUOTE 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV style="FONT: 10pt arial">----- Original Message ----- </DIV>
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black"><B>From:</B> 
  <A title=alex.betis@gmail.com href="mailto:alex.betis@gmail.com">Alex 
  Betis</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>To:</B> <A title=vdr@linuxtv.org 
  href="mailto:vdr@linuxtv.org">VDR Mailing List</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>Sent:</B> Thursday, December 18, 2008 2:32 
  PM</DIV>
  <DIV style="FONT: 10pt arial"><B>Subject:</B> Re: [vdr] Soft RAID-5 + LVM file 
  system corruption</DIV>
  <DIV><BR></DIV>
  <DIV dir=ltr><BR><BR>
  <DIV class=gmail_quote>On Thu, Dec 18, 2008 at 11:20 PM, Timothy D. Lenz <SPAN 
  dir=ltr>&lt;<A href="mailto:tlenz@vorgon.com">tlenz@vorgon.com</A>&gt;</SPAN> 
  wrote:<BR>
  <BLOCKQUOTE class=gmail_quote 
  style="PADDING-LEFT: 1ex; MARGIN: 0pt 0pt 0pt 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">
    <DIV bgcolor="#ffffff">
    <DIV><FONT face=Arial size=2>I started switching to raid but ran into 
    problems with lack of info. 3 500gb sata drives with 3 partitions each. The 
    first 2 are mirrored with 1 spare. That was to be for all the boot abd 
    program files. The second was to be swap and the third which is raid 5 is 
    storage for recordings. I have the recordings in use, but ran into some 
    confusion about setting up the boot stuff. I don't recall the exact problem, 
    but when installing the stuff for raid it did some kind of update, but only 
    to the original kernal which is still there, not to the custom built which 
    is being used. Some the messages pointed to things relating to using a ram 
    disk during boot which is not suposed to be needed when just mirroring the 
    boot area. </FONT></DIV>
    <DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
    <DIV><FONT face=Arial size=2>I was going to also use LVM on the raid 5 part 
    but ext3 wasn't well supported and the other file systems didn't have the 
    full jernaling or something and I also want to set up samba and use some of 
    that space for backing up my windows computer.</FONT></DIV></DIV></BLOCKQUOTE>
  <DIV>What distro did you tried to use?<BR>I've tried Ubuntu about a year ago, 
  but it didn't support any RAID nor LVM configurations in installation stage, 
  so I went back to Fedora, which has all those options.<BR><BR>Configuration is 
  very easily done. The only tricky part is that you have to type some commands 
  manually in fdisk to install MBR on both disks if you want to boot from RAID-1 
  setup.<BR>All the info is available on the net.<BR><BR>By the way, my swap is 
  also on LVM/RAID-5.<BR><BR>I just don't know how to get rid from the node 
  corruptions.<BR>I start suspecting my hardware. Run memory tests many times, 
  but no conclusion so far.<BR><BR></DIV>
  <BLOCKQUOTE class=gmail_quote 
  style="PADDING-LEFT: 1ex; MARGIN: 0pt 0pt 0pt 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">
    <DIV bgcolor="#ffffff">
    <DIV><FONT face=Arial size=2></FONT></DIV>
    <DIV><FONT face=Arial size=2></FONT>&nbsp;</DIV>
    <BLOCKQUOTE 
    style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: rgb(0,0,0) 2px solid; MARGIN-RIGHT: 0px">
      <DIV>
      <DIV></DIV>
      <DIV class=Wj3C7c>
      <DIV 
      style="FONT: 10pt arial; font-size-adjust: none; font-stretch: normal">----- 
      Original Message ----- </DIV>
      <DIV 
      style="BACKGROUND: rgb(228,228,228); FONT: 10pt arial; font-size-adjust: none; font-stretch: normal; moz-background-clip: -moz-initial; moz-background-origin: -moz-initial; moz-background-inline-policy: -moz-initial"><B>From:</B> 
      <A title=alex.betis@gmail.com href="mailto:alex.betis@gmail.com" 
      target=_blank>Alex Betis</A> </DIV>
      <DIV 
      style="FONT: 10pt arial; font-size-adjust: none; font-stretch: normal"><B>To:</B> 
      <A title=vdr@linuxtv.org href="mailto:vdr@linuxtv.org" 
      target=_blank>vdr@linuxtv.org</A> </DIV>
      <DIV 
      style="FONT: 10pt arial; font-size-adjust: none; font-stretch: normal"><B>Sent:</B> 
      Thursday, December 18, 2008 12:51 PM</DIV>
      <DIV 
      style="FONT: 10pt arial; font-size-adjust: none; font-stretch: normal"><B>Subject:</B> 
      [vdr] Soft RAID-5 + LVM file system corruption</DIV>
      <DIV><BR></DIV>
      <DIV dir=ltr>Hello all,<BR><BR>A system question, not so VDR related, but 
      I hope someone in the list use the same configuration.<BR><BR>From time to 
      time my system won't boot since ext3 file system got corrupted and asks me 
      to log in as root and run fsck manually. No bad blocks are found, just 
      incorrectly stored nodes that are always fixed.<BR><BR>I have 3 320GByte 
      SATA disks partitioned to several large partitions, those partitions are 
      configured to software RAID-5 between disks and on those RAID-5 partitions 
      there are 2 LVM volumes, one for system and another for storage.<BR>There 
      are also 250 MByte partition on every disk, while 2 of them are configured 
      to software RAID-1 and mapped to /boot.<BR><BR>System LVM gets corrupted 
      more often since its used more intensively.<BR><BR>Does anybody here have 
      the same configuration? Or any other software RAID-5 configuration?<BR>Did 
      anyone faced such problems? Maybe someone facing the same problem without 
      RAIDs?<BR>Any help will be appreciated.<BR><BR>I'm running on Fedora 10 
      with 2.6.27 kernel.<BR>I had the same problem with Fedora 8 as 
      well.<BR><BR>Thanks.<BR>Alex.<BR><BR></DIV></DIV></DIV>
      <P></P>
      <HR>

      <P></P>_______________________________________________<BR>vdr mailing 
      list<BR><A href="mailto:vdr@linuxtv.org" 
      target=_blank>vdr@linuxtv.org</A><BR><A 
      href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr" 
      target=_blank>http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr</A><BR></BLOCKQUOTE></DIV><BR>_______________________________________________<BR>vdr 
    mailing list<BR><A href="mailto:vdr@linuxtv.org">vdr@linuxtv.org</A><BR><A 
    href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr" 
    target=_blank>http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr</A><BR><BR></BLOCKQUOTE></DIV><BR></DIV>
  <P>
  <HR>

  <P></P>_______________________________________________<BR>vdr mailing 
  list<BR>vdr@linuxtv.org<BR>http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr<BR></BLOCKQUOTE></BODY></HTML>