<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Hi all, I have a main frontend box running yaVDR 1.7.21 vdr and I
    have a version 1 AppleTV with a broadcom crystalhd module
    installed.  I'm running Ubuntu and have loaded from source the
    crystalhd kernel module and the libraries.<br>
    <br>
    I have xbmc-pvr branch from yaVDR running on the appletv and it
    works most of the time but cannot keep up with 1080 most of the time
    (can for 720p).  Does anyone know if this branch has crystalhd
    support and how do I know if its using it?<br>
    <br>
    Second, I would prefer to use vdr-xineliboutput and have installed
    vdr-sxfe and vdr-fbfe.  I don't need, nor want all the overhead of
    xbmc.  I'm thinking if I can one of these to work then it would be
    perfect - I could use the vdr OSD, etc.  However, I can't find a
    video module that will work properly.<br>
    <br>
    vdr-sxfe shows me:<br>
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-1">
    Available video drivers: vdpau aadxr3 dxr3 xv vaapi raw opengl xshm
    caca aa none xxmc sdl vidixfb vidix fb xvmc<br>
    Available audio drivers: pulseaudio alsa oss jack none file<br>
    <br>
    I understand to 'use' crystalhd you have to invoke the vaapi video
    driver?  Is this correct?  When I try it, however, it says <br>
    libva: libva version 0.31.1<br>
    Xlib:  extension "XFree86-DRI" missing on display ":0".<br>
    libva: va_getDriverName() returns 0<br>
    libva: Trying to open /usr/lib/dri/nvidia_drv_video.so<br>
    libva: va_openDriver() returns -1<br>
    <br>
    How can I get around this or is it possible with my setup?  Anyone
    got this going?<br>
    <br>
    Thanks for any help.<br>
    <br>
    Norm<br>
    <br>
    <br>
    <br>
  </body>
</html>