<div dir="ltr"><div><div>Hi,<br><br></div>i have the following problem:<br></div><div>With Ubuntu 12.04 inputlirc doesn't work anymore when using the symlics under /dev/input/by-id/...<br><br></div><div>I have a Hama IR Remote, the symlinks for the remote are:<br>
/dev/input/by-id/usb-05a4_9881-event-kbd -> ../event2<br>/dev/input/by-id/usb-05a4_9881-if01-event-mouse -> ../event3<br><br></div><div>When using this links in /etc/default/inputlirc like the following<br>##<br>EVENTS="/dev/input/by-id/usb-05a4_9881*"<br>
OPTIONS="-g -m 0 -c"<br>##<br></div><div>then inputlirc doesn't start.<br><br></div><div>With the following content:<br>##<br>EVENTS="/dev/input/event2 /dev/input/event3"<br>OPTIONS="-g -m 0 -c"<br>
##<br></div><div>inputlirc starts and works as expected. unfortunately the device (event2/3) changes from reboot to reboot.<br><br></div><div>The upper version of the config (with by-id) has been worked under ubuntu 10.10 without any problem.<br>
<br></div><div>I have tried to create "static" device names with the manual under "<a href="http://wiki.xbmc.org/index.php?title=HOW-TO:Configure_VRC-1100_remote_for_Ubuntu">http://wiki.xbmc.org/index.php?title=HOW-TO:Configure_VRC-1100_remote_for_Ubuntu</a>", but it didn't work. after restarting udev, there was no device "/dev/input/irremote0"<br>
<br></div><div>is it a known bug that lirc doesn't  work with by-id device names ? Have any other the same problem ?<br><br>Regards, Rainer<br></div><div><br></div><div><br></div></div>