Difference between revisions of "DEBIAN Compiling VDR Source Packages"

From VDR Wiki
Jump to: navigation, search
m (link to dxr3 and xineliboutput plugin pages)
m (added warning and more info)
Line 3: Line 3:
 
{{Box Info |  
 
{{Box Info |  
 
If you have a [[budget DVB card]] and need to use a [[Output_devices|software decoder plugin]] such as [[Xineliboutput-plugin]] or a seperate [[Output_devices|hardware decoding device]], such as a DXR3 and the [[Dxr3-plugin]]; this section may be particularly useful to you.
 
If you have a [[budget DVB card]] and need to use a [[Output_devices|software decoder plugin]] such as [[Xineliboutput-plugin]] or a seperate [[Output_devices|hardware decoding device]], such as a DXR3 and the [[Dxr3-plugin]]; this section may be particularly useful to you.
 +
 +
Both plugins are waiting to be accepted into the Debian repository. In the meantime, you can build the packages yourself using the technique described below. Of course, bear in mind that eventually these plugins will be approved and you will then be able to install them normally using apt.
 +
}}
 +
 +
{{Box Warning |
 +
I have only tested this on Debian Unstable and Ubuntu Dapper. It may not work for older releases.
 
}}
 
}}
  

Revision as of 16:46, 20 July 2006

Instead of simply installing the standard binary packages you can instead compile your own packages using Debian packaging tools and sources from the Debian VDR and DVB Packaging Project. This way you get a greater selection and more up to date versions of the VDR packages, plus easy package installation, setup, and if necessary removal.

Info
Info

If you have a budget DVB card and need to use a software decoder plugin such as Xineliboutput-plugin or a seperate hardware decoding device, such as a DXR3 and the Dxr3-plugin; this section may be particularly useful to you.

Both plugins are waiting to be accepted into the Debian repository. In the meantime, you can build the packages yourself using the technique described below. Of course, bear in mind that eventually these plugins will be approved and you will then be able to install them normally using apt.


Warning
Warning

I have only tested this on Debian Unstable and Ubuntu Dapper. It may not work for older releases.


First read [1] and then follow the instructions below.

  • Install svn-buildpackage and its dependencies.
richard@vito:~$ sudo aptitude install svn-buildpackage
Password:
Reading package lists... Done
...etc...
  • Tell svn-buildpackage where to put compiled packages and where to find source tarballs.
richard@vito:~$ echo "svn-override=buildArea=${HOME}/src/debian-vdr/build-area,origDir=${HOME}/src/debian-vdr/tarballs" > .svn-buildpackage.conf
  • Setup a folder to do the package building in.
richard@vito:~$ mkdir -p src/debian-vdr
richard@vito:~$ cd src/debian-vdr/
richard@vito:~/src/debian-vdr$
  • Check out the tarballs. There are alot of them and some are quite large, so this may take a long time.
richard@vito:~/src/debian-vdr$  svn co svn://svn.debian.org/svn/pkg-vdr-dvb/tarballs
A    tarballs/vdr-plugin-nordlichtsepg_0.8a.orig.tar.gz
A    tarballs/vdr-plugin-osdtest256_0.1.0.orig.tar.gz
A    tarballs/vdr-plugin-freecell_0.0.2.orig.tar.gz
A    tarballs/vdr-plugin-xine_0.7.9.orig.tar.gz
...etc...
  • Check out the debian build scripts.
richard@vito:~/src/debian-vdr$ svn co svn://svn.debian.org/svn/pkg-vdr-dvb/vdr/vdr/trunk vdr/vdr
A    vdr/vdr/debian
A    vdr/vdr/debian/control
A    vdr/vdr/debian/config-loader.sh
...etc...
  • Start compiling the package
richard@vito:~/src/debian-vdr$ cd vdr/vdr/
richard@vito:~/src/debian-vdr/vdr/vdr$ svn-buildpackage -rfakeroot -uc -us
Imported config directives:
        --svn-override=buildArea=/home/richard/src/debian-vdr/build-area,origDir=/home/richard/src/debian-vdr/tarballs
        trunkDir: /home/richard/src/debian-vdr/vdr/vdr
        trunkUrl: svn://svn.debian.org/svn/pkg-vdr-dvb/vdr/vdr/trunk
dpkg-checkbuilddeps
dpkg-checkbuilddeps: Unmet build dependencies: libcap-dev
Insufficient Build-Deps, stop!

You will very likely see something like this telling you that you need to install dependencies. So do that and retry.

richard@vito:~/src/debian-vdr/vdr/vdr$ sudo aptitude install libcap-dev
Password:
...etc...
  • If all went well, you should see...
...etc..
build command was successful; binaries are in /home/richard/src/debian-vdr/build-area/. The changes file is:
 /home/richard/src/debian-vdr/build-area/vdr_1.4.1-1_i386.changes
Binary packages:
 /home/richard/src/debian-vdr/build-area/vdr-dev_1.4.1-1_all.deb /home/richard/src/debian-vdr/build-area/vdr_1.4.1-1_i386.deb /home/richard/src/debian-vdr/build-area/vdr-plugin-sky_1.4.1-1_i386.deb /home/richard/src/debian-vdr/build-area/vdr-plugin-examples_1.4.1-1_i386.deb
rm -rf /home/richard/src/debian-vdr/build-area/vdr-1.4.1
richard@vito:~/src/debian-vdr/vdr/vdr$
  • Finally install the packages.
richard@vito:~/src/debian-vdr/vdr/vdr$ cd ../../build-area/
richard@vito:~/src/debian-vdr/build-area$ ls
vdr_1.4.1-1.diff.gz       vdr_1.4.1.orig.tar.gz
vdr_1.4.1-1.dsc           vdr-dev_1.4.1-1_all.deb
vdr_1.4.1-1_i386.changes  vdr-plugin-examples_1.4.1-1_i386.deb
vdr_1.4.1-1_i386.deb      vdr-plugin-sky_1.4.1-1_i386.deb
richard@vito:~/src/debian-vdr/build-area$ sudo dpkg -i vdr_1.4.1-1_i386.deb vdr-dev_1.4.1-1_all.deb